Configuration Profile - Screen Saver (Sierra)

s_oconnor
New Contributor III

Hey All -

Just got done creating all the images for 10.12.2. Our configuration profile for Login and Password holds the screen saver preference. It worked in El Capitan, yet in Sierra it is defaulting to the message screen saver. The one with the apple symbol and the computer name. When the user logs in, the ghost of the apple symbol remains for around a minute each time.

Here is the config profile. On the bottom right you can see it is pointing to the Flurry.saver, which again worked for El Capitan. The file path did not change from what I can tell for Sierra. Flurry is also still available in Sierra.

640237a71b194fe8942139ae71fef3be

Any ideas why even though it is set to select that screen saver, it is defaulting to a different one?

Much thanks ๐Ÿ™‚

1 ACCEPTED SOLUTION

s_oconnor
New Contributor III

SOLVED

This is how I (with the help from those at jamf) got it to work in my environment:

Configuration Profile with Login Window Banner set to have the "Start Screen saver After:" I have 15 Minutes added. Then the file path "/System/Library/Screen Savers/Flurry.saver" (First Screen shot on this thread)

Then I have a script called "ScreenSaver" added to jamf, that then ties into a policy.

#!/bin/sh
currentUser=`ls -l /dev/console | awk {' print $3 '}`
su $currentUser -c "/usr/bin/defaults -currentHost write com.apple.screensaver moduleDict -dict path /System/Library/Screen Savers/Flurry.saver"

killall cfprefsd

ce8c029a701a4668b1ce5a76dc451def

From there I added it into a Policy I called "ScreenSaver/Lock"

115ddd9b5b3044d4a11ea9bd735cd05e

I also added in "Files and Processes" with an "Execute Command" (run command)

"defaults -currentHost write com.apple.screensaver idleTime 15" (This is where those at jamf and I differed. They said to put 900 instead of 15. It is working with 15 for me (or that could be the config profile), so I am leaving it but want to make you all aware).

e0093d0cc23848a4aaeebfd6a6e46745

All those combined have been working on my test group of 12 people. They are running either El Capitan or Sierra currently. All are on version 9.97. I'm sure there are better ways to go about doing this, however this is how I finally got it to work for us, so thought I'd share ๐Ÿ™‚ I will be pushing it out to the rest of the company later today or tomorrow.

Good luck and hope this helps someone.

View solution in original post

14 REPLIES 14

PAC
Contributor

I am getting the actual opposite.
I wish it to show the name for i can tell which computer is which but some are still getting the flurry one from time to time.
I have edited and pushed out to all devices again, i have tried lowering the screen saver start time from 20 minutes to 10.

It will be interested to see how you solve this.

Regards

mdonovan
New Contributor III

Have you created a new Config Profile, or is it a copy of one used with previous Mac OS, or created in a previous version of Casper?

cwaldrip
Valued Contributor

I think that screensaver setting is for the login window, not for the individual users. Regardless, I can't get it to work for the login window, or the user. ๐Ÿ˜›

s_oconnor
New Contributor III

@mdonovan - It is the same one used for all previous OSx. I was thinking of making one that is just for ScreenSaver and define it for Sierra. I'm new to this company, so I'm also guessing it has been used in previous versions of Casper. We have not had the chance to update from 9.91 yet. I know 9.96 is supposed to be compatible with Sierra, however config profiles have never worked the way everyone wished.

@cwaldrip - I did also set a "managed preferences profile" specific to "ScreenSaver by Host" I know it has one for "Login Window" too. I've tried turning off the setting in config profile for screen saver and vise versa, to see if one or the other worked. No luck.

(See below for screen shots)

04676977542f4bc081ed6650fa3e8aba
1ed99ec0e5ac46ca8338722d14348167

Our users on El Capitan are still having Flurry pop up, those on Sierra are getting the Message (Apple symbol/Computer name). It shouldn't be a big deal, at this point though, it's kind of driving me mental.

Any other ideas? (I will try making just one Config Profile specific for screen saver and set limitation to Sierra computers and see what happens)

s_oconnor
New Contributor III

@peter.caldwell - Hopefully I figure it out soon. Once I do. I'll let you know ๐Ÿ™‚

cwaldrip
Valued Contributor

@sabrina.oconnor I think configuration profiles is a dead end, and don't have much hope for managed preferences. I was working down the path of using defaults write when I got sidetracked.

s_oconnor
New Contributor III

@cwaldrip - I agree. After spending way too much time yesterday. I agree. I even tried to add in the managed preferences with login window and had no luck. Those on El Capitan are still fine. Those who used the app store to upgrade from El Capitan to Sierra are fine, yet our company image for Sierra, is not working as planned for the screen saver. I'm hoping when we upgrade the binary it magically fixes it, but I'm not holding out much hope.

s_oconnor
New Contributor III

@cwaldrip @peter.caldwell @mdonovan - Welp, there goes my last idea. Updated our binary to 9.97 (9.96 is compatible with sierra). I was hoping the config profile or managed preferences would magically work and do what they are supposed to. No such luck. I started looking into it more. Even those on El Capitan are getting the screen saver with the message (apple symbol and computer name), when I have it set to flurry. I figure at some point I'll contact the jamf poc and start bugging him and see what we can come up with. Oy.

s_oconnor
New Contributor III

See if this does the trick for anyone...

@cwaldrip @peter.caldwell @mdonovan

!/bin/sh

currentUser=ls -l /dev/console | awk {' print $3 '}
su $currentUser -c "/usr/bin/defaults -currentHost write com.apple.screensaver moduleDict -dict path /System/Library/Screen Savers/flurry.saver" (this is from someone at jamf)

Of course change the path to reflect what screen saver you want to use. Create a script file in jss. Then make a policy and add it into there. I then added a test computer to that policy. After numerous testing and a bit of working around. It seems to finally be working. I do have the "Managed Preferences" set still as well.

s_oconnor
New Contributor III

SOLVED

This is how I (with the help from those at jamf) got it to work in my environment:

Configuration Profile with Login Window Banner set to have the "Start Screen saver After:" I have 15 Minutes added. Then the file path "/System/Library/Screen Savers/Flurry.saver" (First Screen shot on this thread)

Then I have a script called "ScreenSaver" added to jamf, that then ties into a policy.

#!/bin/sh
currentUser=`ls -l /dev/console | awk {' print $3 '}`
su $currentUser -c "/usr/bin/defaults -currentHost write com.apple.screensaver moduleDict -dict path /System/Library/Screen Savers/Flurry.saver"

killall cfprefsd

ce8c029a701a4668b1ce5a76dc451def

From there I added it into a Policy I called "ScreenSaver/Lock"

115ddd9b5b3044d4a11ea9bd735cd05e

I also added in "Files and Processes" with an "Execute Command" (run command)

"defaults -currentHost write com.apple.screensaver idleTime 15" (This is where those at jamf and I differed. They said to put 900 instead of 15. It is working with 15 for me (or that could be the config profile), so I am leaving it but want to make you all aware).

e0093d0cc23848a4aaeebfd6a6e46745

All those combined have been working on my test group of 12 people. They are running either El Capitan or Sierra currently. All are on version 9.97. I'm sure there are better ways to go about doing this, however this is how I finally got it to work for us, so thought I'd share ๐Ÿ™‚ I will be pushing it out to the rest of the company later today or tomorrow.

Good luck and hope this helps someone.

View solution in original post

KSchroeder
Contributor

Really, really ridiculous that these sorts of bugs go on for this long. If you search around here or on Google, you'll find instances of this problem going back to 2013! Pitiful....though still not 100% whether Jamf or Apple is to blame (though I'm leaning towards the former)!

s_oconnor
New Contributor III

Yeah, I spent WAY too much time on something that should have taken but a few minutes. -.- The best part, when I spoke to those at jamf about the "Managed Preferences" where the "Screen Saver" preferences are housed. They informed me that Apple was doing away with those settings and I should not be using them. I took that to mean, that's why they are not working. sigh

daniel_jacobson
New Contributor II

Create your .mobileconfig profile using Apple Configurator 2 or Apple Profile Manager, convert it to a PKG using make profile pkg (https://github.com/timsutton/make-profile-pkg) and deploy it via policy.

Spaceuser
New Contributor

I think there might be a better solution for this. Although I use Profile Manager and not JAMF, it's the same principle. After reading the official documentation from Apple (https://developer.apple.com/library/content/featuredarticles/iPhoneConfigurationProfileRef/Introduction/Introduction.html), there are two different Payload Types for this. We wanted to force the Idle Time for the screen saver. The problem with com.apple.screensaver was that it would also activate a screen saver at the login window and sometimes it wouldn't disable after input from mouse/keyboard (at least in Sierra), so we abandoned that profile setting.

But there is another called com.apple.screensaver.user, which still is a device level type (luckily). There was our solution with the Key "idleTime". Your problem with the specific screen saver module you want to use should be solved with the Key "modulePath". Seems a more clean and stable solution than the above mentioned script.