Cylance noui uninstall.


I am trying to use the the Cylance noui switch with the uninstall script provided in the Uninstall
if I do this line /Applications/Cylance/Uninstall CylancePROTECT --noui as a policy out of Self Service the product uninstalls but it then throws a failed to install message because in the policy logs for the user I get this message.
Result of command:<br/>2018-07-25 12:28:34.432 Uninstall CylancePROTECT[15408:202794] doDeleteMemDefFiles for path /private/tmp/<br/>2018-07-25 12:28:34.500 Uninstall CylancePROTECT[15408:202794] Execution of /bin/rm failed with code 1
If I run the same policy with the uninstall app allowing the UI then I do not see that error being thrown in the policy logs and the uninstall completes successfully. if I check the logs on the machine I can find the same error doDeleteMemDefFiles for path /private/tmp/.

Has anyone seen this and found a resolution?


Valued Contributor II

How are you running that command? In a script? I guess I would add an 'exit 0' at the end which I think makes JAMF issue a success for the script regardless of other output.

New Contributor II

I'm getting the same errors when I run the command locally in Terminal. I opened up a support request with Cylance. They had me send them the output of an opensnoop trace while I executed the command. They couldn't find what was causing the error(s). They want me to send them some more snoops and run their support tool. However, I haven't got to that point. The command has got to run locally error-free before it can be deployed.
Let me know what you find.

Contributor II

I am seeing the same thing here. Waiting on support.

Ever figure this out?

Valued Contributor II

Just checking. Are you unloading the launch daemon first?

launchctl unload /Library/launchdaemons/com.cylance.agent_service.plist

Contributor II

thanks @Chris_Hafner I haven't tried that yet, but thats exactly what Cylance support got back to me with. Hopefully it works.

  1. Stop the service

sudo launchctl unload /Library/LaunchDaemons/com.cylance.agent_service.plist

  1. Delete the values.xml file

sudo rm /Library/Application Support/Cylance/Desktop/registry/LocalMachine/Software/Cylance/Desktop/values.xml

  1. Re-run uninstaller

Silent Uninstall

sudo /Applications/Cylance/Uninstall CylancePROTECT --noui

New Contributor III

@szultzie were you able to get that working?

New Contributor II

I got this working by putting the above Silent Uninstall command in a policy with Files and Processes. It does Uninstall Cylance completely. It does leave the Cylance Uninstall icon in the dock however....

The issue I am seeing now is, for whatever reason, Cylance (1580 version), when installed, Hangs jamf recon at the Locating hardware information line, so recon never completes...

New Contributor

We are deploying Jamf in our organization and will replace Cylance with Jamf Protect. I'm not real great with scripting. Would anyone be willing to share the scripts they got to work for uninstalling Cylance in the background?