DEP iPad cant download configuration

Contributor III

While JSS is working fine and some iPad are enrolling into JSS normally. On DEP iPads we are getting message. "The configuration for your iPad can not be downloaded. The configuration is not available." Any suggestions.


Valued Contributor

Reboot the iPad. It will work the second time.

New Contributor

I noticed this today as well. I just waited a minute or 2 and went back and tried again and it worked.
Sometimes took 2-3 goes but it eventually worked.
also noticed that after getting past that section and getting to the authentication for the enrolment, it locked out the keyboard for a few seconds. Could do other things like close the keyboard and change from username to password, even paste the username. But couldnt type anything.

I just put it down to DEP server latency.

Contributor III

We get that all the time, not sure what the problem seems to be. Waiting for a few minutes does the trick.

Valued Contributor

Had this a few times. Starting again sometimes fixes it or updating the IOS to latest version will also fix it.

Valued Contributor III

Usually it is related to the time not being updated by time servers yet - you can look at the top of the screen and see the time zone update if you are not Pacific time and then try again. Sometimes you just have to reboot the iPad..


Is there a real solution to the time zone problem? The iPad I am testing keeps starting it PST which fails since we are in EST.

Valued Contributor

Does anyone know how to make an iPad update it's time during the setup stage? Getting iPads stuck on the wrong time and can't download their setup profiles.

New Contributor

I was running into this problem with a DEP iPad today. It came out of the box with 10.3, and I tried setting it up, but was getting the error, "The configuration for your iPad can not be downloaded. The configuration is not available." This was also showing me the touch ID and some steps that we normally skip or are always after the MDM account sign-in.

I plugged into configurator to wipe and restore to the latest (11.2.6), but it still gave the same error during setup.

I resolved by disconnecting from our campus/school network, and using a hotspot from my ATT iPhone to try again, and this time it caught the profile before touch ID or passcode or anything, and allowed me to login the username/password as normal.

Things I noticed are, the iPad time was showing "12:46AM" while it was 10:23AM here (Philadelphia, Eastern time). I've usually only seen iPads showing pacific time but this one was way off for some reason. I also noticed it was completely dead when I pulled it out of the box, so perhaps it never got the chance to update to pacific time (whenever that might normally happen).

Also, as soon as I connected the iPad to my hotspot, it updated the time TO PACIFIC. (7:46AM, 3 hours back from where it physically is). So I'm assuming, there is a validation or verification of a certificate when the device tries to get the configuration, but the time zone being so off was enough to prevent that handshake. But the time zone being pacific is good enough to get through.

Anyway, dunno if that helps anyone out—I don't know what in our school network is being blocked that the iPad couldn't pull the pacific time that it wanted.

Valued Contributor

Maybe unrelated, but hard to know for sure. I just had an issue where an iPad was returned from Apple, who updated it to iOS 11. Our entire fleet is locked to 10.3.3 until Summer 2018, at which time they'll be upgraded. The iPad would not complete the download the configuration profile unless I removed it from the PreStage enrollment group. Then it would let me set it up and manually enroll it, but then it would not be supervised.

JAMF tech support helped me to figure it out. In November, I had put a RapidSSL 3rd party cert on my JSS, effectively replacing the self-signed cert that is created during JSS setup. But, unknown to me, each of the PreStage enrollments I had created were still pointing to the self-signed cert. So, during attempted enrollment during Setup Assistant, it would not continue. Once I removed the self-signed cert from the Certificates section of each affected PreStage, it worked as designed.