Deploying Deepfreeze in Mac 10.14 Mojave

New Contributor

Hi Ya'll,

I am in need to deploy Faronic's Deepfreeze application to our student labs that run 10.14. I used the Snapshot future on Composer. When I get the policy to deploy and I try to open up the application of ‘Communication error - unable to communicate with DeepFreeze Damon’. But with the completed snapshot I do see that the Deepfreeze Damon is in the library. 6be2e1c3a692410fae309d98d6be43a1.

What I do:

  1. Build this package on a VM
  2. Downloaded the dmg from Faronics on a different laptop
  3. Select APFS dmg and move that DMG to the VM
  4. Take first snapshot on Composer
  5. Start DMG install
  6. Once that is complete check to see if Faronics is in my application folder
  7. Open up Deepfreeze application configure thawspace and password enable.
  8. Close Deepfreeze and reopen to see if all my configurations were saved.
  9. Take the second snapshot and save as DeepFreeze.pkg
  10. Drag to JamfAdmin
  11. Created a policy that contains DeepFreeze.pkg
  12. Deployed to test Mac Mini on 10.14 and get Communication Error stated above.

Has anyone encountered a similar problem? If so what was your solution. OR Has ANYONE been able to successfully deploy Deepfreeze? If so please share!


Contributor III

I had heard that they currently don't have a working version for Mojave. I know they had trouble with AFPS. Article. In this statement they recommend removing deep freeze before upgrading because of issues related to AFPS.


@sharriston they actually just updated with AFPS support recently:

As for packaging this, in the past they have an application that you use to create the packages to deploy. I think you should start there as composer not worked in the past for this.

New Contributor

@rhoward I was aware of the previous application that was part of the installer for HFS, but unfortunately, the new APFS installer doesn't include the 'Create an installation package option'.

New Contributor II


So, i hope I'm not missing anything here, but why don't you just use the built in pkg-installer that they provide?

I know that there is not much documentation to DeepFreeze with APFS support, but this is what I'm going to do:

  1. Use JAMF to distribute the pkg
  2. Use binary to create settings, such as serialize: /usr/local/bin/deepfreeze license --set [serial number]
  3. Freeze: /usr/local/bin/deepfreeze freeze --volume [volume name}

As you can see if you call binary, you can also set password, uninstall, set thawspace and more. What does not seem to be included as of now is the scheduling part, but you can easily let JAMF do that for you by simply script it to unfreeze.

Freeze on!

New Contributor II


How are you scheduling the thaw, updates, re-freeze process. How does machine know when to freeze or is it just on a time period. Is the time to run built into the script or set via JSS?

New Contributor

We are running into a similar issue here. New Deepfreeze on Mojave does not work the same way. We use ARD to globally freeze and thaw, but that is no longer an option. I have a ticket open with Faronics. Could anyone help with respect to scripting "boot thaw" and "boot frozen" ?

I tried the following in ARD, it says "completed", but it does not work.

BOOT THAWED: DFXPSWD="password"/usr/local/bin/deepfreeze -u "User" -p bootThawed

BOOT FROZEN: DFXPSWD="password" /usr/local/bin/deepfreeze -u "User" -p bootFrozen

New Contributor III

As one of my colleagues found, here are the commands:

Set Boot State to Thawed after reboot: DFXPSWD="password" /usr/local/bin/deepfreeze thaw --startup --env Set Boot State to Frozen after reboot: DFXPSWD="password" /usr/local/bin/deepfreeze freeze --startup --env

This will set it to the desired state after reboot.

Reboot Thawed: DFXPSWD="password" /usr/local/bin/deepfreeze thaw --startup --env | shutdown -r now
Reboot Frozen: DFXPSWD="password" /usr/local/bin/deepfreeze freeze --startup --env | shutdown -r now

Also of use:

Use these if you need a password that operates independent of an administrator password (I believe any admin level account will work to open the application).

Set Password: DFXNEWPSWD="password" /usr/local/bin/deepfreeze password add --description dfadmin --env
Enable Password: usr/local/bin/deepfreeze password enable

Get Status: DFXPSWD="password" /usr/local/bin/deepfreeze status --env

As to maintenance times, I don't think I've seen that as an option yet. I'd love it, but so far nothing.

Contributor III

Just throwing this out there...can you get away from using Deepfreeze? When I took over Mac support I found Deepfreeze to be more trouble than it's worth(and we got it pretty cheap). I moved our DeepFreeze labs to being cleaned by a script on log out and the accounts were changed from being admin to standard users. More or less I feel it's much more in line with what Apple supports and it works well.

Even on the Windows side there were guys who swore up and down by Deepfreeze and due to issues with it there they started using scripts to do the same thing and are now questioning if it's worth the hassle to go back to it.

New Contributor II

I have now been able to successfully deploy deepfreeze to Mojave with Enterprise (I am assuming this will work with older versions as well since this is a simple fix).

The "cannot communicate with Daemon" issue is not due to how the Program is packed, but how the client is receiving the package. I don't think JAMF is actually perfectly mirroring a normal install - In this case, it's just dropping the files, and not initializing the Daemon. The system is looking for a plist daemon for Deepfreeze that isn't running!

All we need to do to fix this is get launchd to see the daemon an initialize it. Since this happens on reboot, I just included a reboot postscript to run when the package installs (DF is the last step in my imaging workflow).

Have you tried turning it off and on again? :)

New Contributor II

I have also been successful in deploying DeepFreeze to Mojave. Performed the install, started DF (without rebooting), enabled passwords, created user, set drive to freeze, set restart to thawed but again, did not reboot, and then created the package. In policy I just set it to reboot after install.