Disable Siri setup assistant in macOS Sierra

pawel_kopocz
New Contributor

Hi,

does anybody already found solution how to disable Siri setup during first configuration? So I'm using script to disable iCloud, diagnostics and setup windows and enable location services however in macOS Sierra we also have window to enable or disable Siri. I tried with script to modify com.apple.SetupAssistant.plist same as with iCloud but with Siri it's not working.

Any ideas or working solutions?

2 ACCEPTED SOLUTIONS

Retrac
Contributor

[This man has you covered - Suppressing Siri pop-up windows on macOS Sierra](link https://derflounder.wordpress.com/2016/09/20/supressing-siri-pop-up-windows-on-macos-sierra/)

View solution in original post

frank
New Contributor III

Hi @pawel.kopocz

Do the setup assistant manually then visit /Users/~/Library/Preferences/com.apple.SetupAssistant.plist

Seems like there's a new key for it called DidSeeSiriSetup.

Put this command in your script/workflow and it should skip it, I haven't had a chance to test myself yet.

/usr/bin/defaults write com.apple.SetupAssistant "DidSeeSiriSetup" -bool true

Cheers,

Frank

View solution in original post

7 REPLIES 7

Retrac
Contributor

[This man has you covered - Suppressing Siri pop-up windows on macOS Sierra](link https://derflounder.wordpress.com/2016/09/20/supressing-siri-pop-up-windows-on-macos-sierra/)

frank
New Contributor III

Hi @pawel.kopocz

Do the setup assistant manually then visit /Users/~/Library/Preferences/com.apple.SetupAssistant.plist

Seems like there's a new key for it called DidSeeSiriSetup.

Put this command in your script/workflow and it should skip it, I haven't had a chance to test myself yet.

/usr/bin/defaults write com.apple.SetupAssistant "DidSeeSiriSetup" -bool true

Cheers,

Frank

plawrence
Contributor II

@pawel.kopocz Do you mean during the after imaging Adobe Temporary Installer account? I cant find a way to stop that one from appearing. It looks like the adobeinstall account doesnt get a home folder created, so it doesnt get the preferences from the User Template that are created by rtoutons scripts.

pawel_kopocz
New Contributor

@Retrac @frank Thanks guys, it's working now!

cgiordano
Contributor

I know that you've got it worked out already but I'd definitely recommend going this route, especially if you don't want your users to Enable Siri at all.

https://www.jamf.com/jamf-nation/discussions/21154/macos-x-sierra-went-gm-anyone-kill-siri-yet

Vanegas
New Contributor

@pawel.kopocz I too am struggling in disabling Siri at the second reboot during a Casper imaging workflow.
How exactly did you get passed this issue?

jgrubbs
New Contributor III

I ran both of these commands but neither were successful:

sudo defaults write /System/Library/User Template/Non_localized/Library/Preferences/com.apple.SetupAssistant DidSeeSiriSetup -bool TRUE
/usr/bin/defaults write com.apple.SetupAssistant "DidSeeSiriSetup" -bool true

Users are still prompted to sign in with an Apple ID.

Any other ideas?