Dymo Label Software/Dymo Connect


We're in the middle of a large upgrade to Big Sur and we're discovering the Dymo Label Software no longer works on Big Sur, and the app to use instead is Dymo Label Connect. The new Connect app isn't great, and the biggest problem for us will be that it no longer can use a local address book, which means our users will lose years of contacts they've been building in the Dymo Label Software app. We have hundreds of Dymo Twin Turbo 450 printers, so this is a big headache...

Does anyone else use Dymo Labelwriters and deploy the Connect app through Jamf Pro? The Connect app doesn't seem like a straightforward deployment, and it looks like I'll have to account for its helper tool and permissions needed, so any advice there would be appreciated. Like I mentioned above, even after I have it deployed, the new Dymo Connect app is a huge problem for us, mostly because of how it handles contacts/saved addresses. Maybe there is a better option than the Dymo Connect app for printing labels with Dymo printers?



I have the same issues and there are more and more apps needing the Privileged Helper app and it is an headache because you have to enter the admin password on first launch. Since the my users all have their own account, setting this up means I need to input the admin password on every single of them.


I have thought about not using the Dymo software, but it's a lot work to use something else. I can use Word to create label and print to it, but I have to do my own measurement etc. I wish it can be more universal like Avery labels which I just fill in the blanks, the Dymo is definitely more convenient.

We ended up continuing to use the old DLS software deployed via Jamf through Self Service policy, and haven't had any issues despite it being listed as not compatible. No issues on either Intel or Apple Silicon, Big Sur or Monterey. We exclusively use Twin Turbo 450s.

I expect we'll keep using DLS until forced off it. The new Dymo Connect software is pretty bad all around.

While not exactly the remedy for my situation, this response helped me by giving me hope that a solution was possible.  In the end, I located the software for my Macbook Pro Monterrey OS here: https://www.dymo.com/support?cfid=dymo-compatibility-chart.  I selected "Driver & Software Downloads" on the left, then on the right chose "Not sure which software to choose?".  Then "Search by Machine" (Dymo model), Select Operating System\MacOS\MacOS 12 Monterey\"DYMO Connect For Desktop V1.4.4 For MacOS 12 Monterey".  I installed the .dmg and was in business.  Thanks!


To my surprised, some schools already have the new 500 series and my hands are tied.

Yikes, I wasn't aware there was a new model. I better order one. Thanks!

I tried to use "Allowed Team Identifiers" but it never worked for me. Changing to "Allowed System Extensions" is working.

New Contributor III

How did anyone make this work on Catalina? I'm struggling to make it work. Composer is useless, wrapping it into a folder with script gives me an error, telling me to contact software manufacturer,... I really hate this software

What are you trying to achieve? I just upload the PKG through JAMF Admin (on-prem), if you are using the older Dymo model, you can use the older DLS program

New Contributor III

Screenshot 2022-02-08 122043.png

I get that error, when I just dump the pkg that's within the dmg that I've pulled from Dymo. If I try to convert it via Composer from Source, it fails after 30%

I only use Composer only if I must, otherwise most software already has PKG that you can simply upload and deploy. For the Dymo 8.7.5, I just upload the PKG and it deploys without issues.


27375TEST (30306)

Sending Wake On LAN command...
Opening SSH Connection to
Accepting authentication method...
Successfully authenticated.
Verifying Computer's Identity...
The MAC Address has been verified.
Checking Operating System Version...
Running macOS 11.6.3 (20G415)
Verifying /usr/local/jamf/bin/jamf...
/usr/local/jamf/bin/jamf version is 10.35.0-t1640197529
Preparing Policy...
Downloading http://tsc-fs01.rsd38.ca/jamfshare/Packages/DYMOLabel-8.7.5.pkg...
Downloading http://tsc-fs01.rsd38.ca/jamfshare/Packages/DYMOLabel-8.7.5.pkg...
Verifying package integrity...
Installing DYMOLabel-8.7.5.pkg...
Successfully installed DYMOLabel-8.7.5.pkg.
Submitting log to https://casper.sd38.bc.ca:8443/


That's the thing. I can't get a clear log and Console shows nothing that would point to the issue

Check your PM, I've sent my package link for you to try. Came straight out of my repository.


md5 /Volumes/jamfshare/Packages/DYMOLabel-8.7.5.pkg 
MD5 (/Volumes/jamfshare/Packages/DYMOLabel-8.7.5.pkg) = e9fc5a930aae6d9422b914e49ec74663

Valued Contributor

Anyone ever figure out how to silently deploy? The package does _most_ of it, and the config profile for the system extension does some, but then it prompts to install a helper that requires admin... after that, it was prompting to add some certs and I can't seem to run that silently. =/ 

I had some luck packaging it up with Composer and deploying that and the config profile, but in the end our users hated the new app so much, we decided to switch to Seiko label printers.