EDU profiles don't get pushed anymore

New Contributor

We are working with JSS: 9.98, Apple School Manager, the Classroom app and shared iPads (all 10.3). Up to last month, everything worked perfectly: whenever you added a class, modified the class members, etc ..., the education profile got pushed to the devices of the students and teachers.
But last weeks, nothing gets deployed or pushed anymore. Standard configuration profiles, apps and other commands get pushed and work perfectly, but education profiles remain the way they were a couple of weeks ago. What was present on the devices keeps working, but no new classes can be added, new students are not added to their class, etc ...


Release Candidate Programs Tester

@dbzict School Manager came out of beta a couple of weeks ago.. might be that you need to update to 9.99.0 to resolve this.. as the update might have changed somethings.

New Contributor

I was wondering if you found out what the issue was?

I am running into this exact issue. Two weeks ago, everything worked fine. Last week the EDU profile stopped updating on Non-Shared iPads. I can add a group of shared iPads to a class and that will pull the class information almost instantly, however assigning new teachers to their iPad in the "User and Location" menu will not pull classes. It doesn't even say that the EDU profile installation was even attempted in the management tab of the iPad.


This is our exact situation as well. Non shared iPads. Classes made manually via Smart Groups of iPads
Tests Performed:
Remove user from iPad User & Location - Results in: Apps are removed, Installed App List and Profile List are sent but we do not see an updated "Install Configuration Profile EDU".

When we look further down the Management History, we see multiple Install Configuration Profile EDU in the past. Just not lately.
JSS - 10.6
iOS above 11.3.1 and below 12.0


Update: Restating the Tomcat service on the Jamf Pro server enable the EDU configuration profiles to start again.