El Capitan Upgrade failing

markc0
New Contributor III

HI All

We up to 10.11 have been at build time creating a separate partition and copying the /Users folder to this separate partition and then createing a sym link on the boot partition of the /Users.
This has worked well, now with the 10.11 in-place installer.
If we try to run the Os X El Capitan.app installer over the top of a 10.10.5 system that has the split disk this errors out.
I know this is down to the split disk as if i run the installer on a non split disk it works fine.
Is anyone else having these issues or is everyone installing a fresh?

thanks

6 REPLIES 6

davidacland
Honored Contributor II
Honored Contributor II

We've had that same setup and used the in-place upgrade approach for earlier OSes. Haven't tested it on 10.11 yet with the split partition but can vouch for it working on 10.10 and earlier.

Are you building the installer with createosxinstallpkg?

markc0
New Contributor III

HI Yes I created a pkg from createosxinstallpkg and also I tried the downloaded os x el captan.app installer

Both have same results

TimT
Contributor

@markc0

Yep, seeing exactly the same thing and we are using the same split partition set as yourself. Always used Greg Neagle's tool and never had an issue til El Cap. Curiously out if the 10 or so test runs one didn't fail. I haven't tried over a single partition so it does look like it's not handling the symlink. Will pore through the log file again today so see if it yields anything useful.

davidacland
Honored Contributor II
Honored Contributor II

I would probably test:

  • Replacing the symlink in / with a Users folder
  • Install the OS from the package (I'd hope this wouldn't fail as the Mac would be "normal" at that point)
  • At reboot (after the install), delete the /Users folder and put the symlink back in

markc0
New Contributor III

Yep, i have removed the symlink and placed /users back on the main partition and then ran the package
this worked fine and then re-ran my script to move the /users & create the symlink.
This worked fine, i just gotta script this now

bentoms
Honored Contributor III
Honored Contributor III

@markc0 FWIW, we partition the Macintosh HD then use FSTAB to mount the Users partition to /Users.

That seems to still work across OS updates.

Some details here