Error: An error occurred attempting to mount the package

Not applicable

Seems to be happening with every package I create and try to deploy. Attached a log below:

Sending Wake On LAN command...
Opening SSH Connection to 152.146.193.xxx...
Accepting authentication method...
Authenticating...
Successfully authenticated.
Verifying Computer's Identity...
The MAC Address has been verified.
Checking Operating System Version...
Running Mac OS X 10.8.4 (12E55)
Verifying /usr/sbin/jamf...
/usr/sbin/jamf is current (8.7)
Verifying /usr/sbin/jamfvnc...
/usr/sbin/jamfvnc does not exist.
Verifying /Library/Preferences/com.jamfsoftware.jamf.plist...
Preparing Policy...
Executing Policy 2013-07-15 at 11:20 AM | user | 5 Computers...
Mounting afp://server/CasperShare to /Volumes/CasperShare...
Installing Lexmark X945e Drivers.dmg...
Error: An error occurred attempting to mount the package "Lexmark X945e Drivers.dmg".
Unmounting file server...
Submitting log to server...
Finished.

12 REPLIES 12

donmontalvo
Esteemed Contributor II

Spaces?

--
https://donmontalvo.com

Not applicable

Not sure what you mean by that?

plawrence
Contributor II

Hes saying there are spaces in your .dmg file name. Do you see the same error when deploying a package without spaces in the file name? Also, try connecting to the CasperShare manually from the machine you are doing the install from and see if you can mount the .dmg

donmontalvo
Esteemed Contributor II

Have you tried taking the spaces off the DMG name?

Error: An error occurred attempting to mount the package "Lexmark X945e Drivers.dmg".
--
https://donmontalvo.com

Not applicable

Have spaces in many of our packages without issue. I've gotten another user here to package it up without issue. So it seems isolated to my setup.

rodderz
New Contributor

Im getting the same thing but have no spaces in my package names - only _ and -
Would be interested to see what the problem is.

Funnily enough they deploy (pkg's) and run normally when you run them locally.
Just trying them over a casper policy now.

lparks
New Contributor

Had a similar issue with 9.01, after talking with JAMF support, it ended up needing a 'sudo chmod 755 mypackage.dmg' before uploading to Casper Admin, was able to get it to push out after that.

agirardi
New Contributor II

usually winds up being the problem here as well. chmod 755 is the common resolution for us as well in this case.

systems_support
New Contributor

I just recently started seeing this error for the first time. I tried the chmod command and tried rebuilding the package to no avail. Then I noticed all of the failed policies were on machines that were updated to 10.11.5 (latest version of El Capitan) but had not rebooted since getting 10.11.5. Once I rebooted the machines, the policy worked fine.

wILLwILL2
New Contributor II

Thanks all. The resolution - 'sudo chmod 755 mypackage.dmg' before uploading to JAMF pro is still valid.

For some reason, I am not able to change the permissions on the .DMG, even as root

Error: Operation Denied

Have you run into this?

sdagley
Honored Contributor III

Another reason to use https downloads from a DP whenever possible since that ensures the downloaded .pkg/.dmg will be accessible.