Flash Player update

Valued Contributor II

Version Release notes were unavailable when this listing was updated.



Download .pkg - http://www.adobe.com/products/flashplayer/distribution3.html

Security Bulletin -

Adobe Security Bulletin:

APSB14-04: Security updates available for Adobe Flash Player


APSB14-04: Security updates available for Adobe Flash Player

Originally posted: February 4, 2014

Adobe has released security updates for Adobe Flash Player and earlier versions for Windows and Macintosh and Adobe Flash Player and earlier versions for Linux. These updates address a vulnerability that could allow an attacker to remotely take control of the affected system.

Adobe is aware of reports that an exploit for this vulnerabilty exists in the wild, and recommends users of Flash Player update their software installations using the instructions provided in the "Solution" section of the security bulletin.

Learn more: http://click.mail.adobesystems.com/?qs=7601182c8a26a0f1ca824e855b424dbe5c173dadd6cd34fb161541bfafd58611e2baddedd9cc6aac

Priority and Severity Ratings:

Adobe categorizes these updates as priority 1, addressing critical vulnerabilities:


Valued Contributor II


APPLE-SA-2014-02-04-1 OS X: Flash Player plug-in blocked

Due to security issues in older versions, Apple has updated the
web plug-in blocking mechanism to disable all versions prior to
Flash Player

Information on blocked web plug-ins will be posted to:

New Contributor

My initial testing of the Flash 12.0.044 update has shown that the plugin will not work, until the Flash Player cache is emptied. I am running the following script on the machine after installing the plugin:

users=$(dscl . -list /Users uid | awk '$2 > 510 {print $1}' | sort)

for user in $users; do

sudo rm -r /Users/$user/Library/Preferences/Macromedia/"Flash Player"/* sudo rm -r /Users/$user/Library/Caches/Adobe/"Flash Player"/*


Valued Contributor II

worked for me without having to touch the cache.

Not applicable

Same, extracted the .pkg from the normal download, deployed using afp, no cache issues. @josaxo are you installing .44 while Safari or Firefox are running (ie recurring check-in)?

Valued Contributor II

I am having no issues with at all. I always trigger my Flash updates at login to minimize the chance that any browsers are open.

Not applicable

@dgreening that's what Self Service is for! "Close Safari and/or Firefox before clicking install" etc.

Contributor III

On a similar note, in that it is related to Adobe Flash, where, or what, is the XProtect mechanism in Mavericks? The xProtect file on my machine, that I had used in the past to keep up to date doesn't seem to have been updated in quite a while. Is the file still in the same location that it was in Mountain Lion?


Not applicable

Spoke too soon - several of my users have reported that Flash stopped working after deploying this 12.0.044 version. Going to add @josaxo's cache script..

New Contributor III

Thanks. I tried @josaxo's script and everything else mentioned here to no avail. Did Adobe do something drastically different with this update?

New Contributor III

Thanks. I tried @josaxo][/url's script and everything else mentioned here to no avail. Did Adobe do something drastically different with this update?


Anyone know where I can find the link to download flashplayer

Not applicable

@j99mac try here:



Thanks for the link. It looks like the version that they have is not the version I am looking for. Anyone know if flashplayer is a Mac version and if so where I can download it?

Not applicable

From http://helpx.adobe.com/security/products/flash-player/apsb14-02.html

Adobe recommends users of Adobe Flash Player 11.9.900.170 and earlier versions for NPAPI plugin-based browsers on Windows update to the newest version by downloading it from the Adobe Flash Player Download Center, or via the update mechanism within the product when prompted.

Valued Contributor II

Yep, just know that said version is blocked (by Apple)