How do I stop iPad from being prompted to Sign in to iTunes?

d_logue
New Contributor II

I have iPads that I have enrolled in Casper with DEP, but after activationsetup there is a re-occuring prompt to "Sign in to iTunes to allow Casper to manage and install apps. With the ability now to deploy apps without an Apple ID, I have no reason to log these iPads in to the App Store but I can't find what is causing this prompt or how to stop it.

5 REPLIES 5

d_logue
New Contributor II

I figured out what I did wrong. I had a free app assigned to the iPads, but I did not have the app added to the app catalog so that I could use VPP to deploy it. Once I added it to the App Catalog and set it to use VPP, I no longer got the prompt.

rchawla
New Contributor III

That solution did not work for me - unless I'm not understanding where the app catalog is in Casper. I have the device-assignable free app added under Mobile Devices>Apps, properly scoped, but the request for iTunes still appears on the iPads.

d_logue
New Contributor II

That is the correct location, but on the VPP tab for the app do you have Assign VPP Content checked?

davidacland
Honored Contributor II
Honored Contributor II

I had the same symptom a few months ago. It was due to a free app not being added / deployed via VPP.

vnjamfnation
New Contributor

This prompt pops up for me when the following is enabled...even for supervised devices

Make app managed if currently installed as unmanaged
Manage the app if it is currently installed as an unmanaged app (the user is prompted to allow management on unsupervised devices)