Imaging Fusion Drive iMacs


We recently bought two fusion drive iMacs, which I have had issues imaging, because they don't seem happy just taking a standard image from Casper (we are running v9.22). Best guess is Casper doesn't support Fusion drive imaging (well I can't find any option to let it know it is handling a Fusion drive setup), please let me know if I am wrong plus I did not see the point of setting up Deploy studio just to do two iMacs.

Consequently I ended up doing the following and it took about an hour to finish;
I am recalling from memory here, but this should work.

In this case, we had two 27" iMacs with a 3TB Fusion drive.
To image one using Casper with our 10.9.1 image, I had to;

1. Remove the Fusion and CoreStorage group

Netboot into Casper and run Terminal.
Execute command diskutil cs list and copy the ID string next to Logical Volume Group
Delete the Fusion / CoreStorage group by using diskutil cs delete <Logical Volume ID here>

Now format the storage drive, in this case the 3TB HDD, using Terminal command diskutil eraseDisk HFS+ "Macintosh HD" <disk ID>
(You can not format the disk using the diskutil GUI as it knows the drives are meant to be a Fusion setup, so it will ask you to repair before the GUI will work with the drives)

2. Now you need to recreate the Logical Volume Group, using Terminal, do the following;

Execute command diskutil list and note the disk ID number of the SSD and the Storage drive. Usually the SSD will be disk0 and the Storage disk will be disk1.

Execute diskutil cs create Fusion <SSD ID here> <HDD ID here> (you can replace "Fusion" with any name you desire, as this is just a name for the group volume)
Execute diskutil cs list and copy the Logical Volume Group ID and note the combined capacity of the Fusion drive. In my case, the total capacity would be 3.1 TB as our iMacs have a 128 GB SSD with 3TB HDD

3. Recreate the Fusion drive volume

To do so, execute the following command diskutil cs createVolume <Logical Volume Group ID> JHFS+ "Macintosh HD" <Capacity of the Fusion drive>. Capacity must be in XXX.Xg for volumes less than 999.99GB in size, or X.Xt for volumes 1.0TB or greater
eg. diskutil cs createVolume <Logical Volume Group ID> JHFS+ "Macintosh HD" 3.1t or
eg. diskutil coreStoreage createVolume <Logical Volume Group ID> JHFS+ "Macintosh HD" 3.1t

When completed, you will see this output Finished CoreStorage operation

4. Image the storage drive (Macintosh HD) as you normally would, but do not check the "Reboot" option. When imaged, proceed to the next step

5. Now you need to boot into internet recovery by restarting the Mac and holding CMD+R, once in recovery, reinstall Mac OS X from Apple, this seemed to take about 5 minutes to download (based on a 10Gb/s connection) and about 30 minutes to install.

Once it has reinstalled OS X, it will reboot and you will find that it will boot into your image that you previously copied to the iMac.

NOTE: If you are planning on running Windows via BOOTCAMP on an iMac like this, when following step 3, make sure to specify a partition on the Storage drive to use in the Fusion setup so that it does not erase your BOOTCAMP partition, eg. diskXsY where X = disk ID and Y = partition ID.

BOOTCAMP will also not take any advantage of having a Fusion drive as it is a Mac OS feature only.

If I have missed anything or you would like to add something to this, please feel free to leave a reply and I will update this post accordingly if necessary.

Most of what I found came from the following website:

specifically from sections Make your own Fusion Drive and How to make your own Fusion Drive

EDIT 4th June 2014 Amended workflow.


Thanks for sharing. This is very useful.

Valued Contributor II

I have an automated script/app for the regular drives, the next question is how to automate this?

Valued Contributor II

Hi Sean,

First of all, thanks so much for your post and for sharing your workflow for getting Fusion drives to work and image as we’d expect.

We do currently have an open defect in which we see an inability to image a Fusion drive if it is a single partition, or if it’s a Fusion drive that we’re trying to partition via an imaging configuration.

For reference, the defect ID is D-006180. I linked this discussion in our workarounds section as it may be helpful for other customers who have cases open with the same issue.

We have found, in some cases, that manually partitioning drive with Disk Utility prior to running Casper Imaging can help in avoiding the problem and allow Casper Imaging to image as we’d expect it to.

If you haven’t already opened up a case with your Account Manager, I’d recommend doing so so we can get it attached to the defect for tracking and documentation purposes; when you e-mail or call them, just reference defect ID D-006180 and they can get a case created and attached.

Amanda Wulff
JAMF Software Support

Valued Contributor

I started down this path with two new (late 2014) Mac Mini's. I thought it was an OS mis-match. I was able to image the fusion drive just fine, but it wouldn't boot from it. I could get to the recovery partition though, and through the command line I was able to use...

bless -mount /Volumes/Macintosh HD -setBoot

Restarted to the bootloader (option key) and there was the boot volume. Machine restarts fine. Not sure if this will help everyone as I've only tested on these Mac Mini's (EMC 2840).

Valued Contributor

It seems my problem was imaging the Mac Mini in Target mode and not restarting when the image was done. Booting the Mac Mini from a boot drive and restarting after imaging worked just fine. My support contact says the original issue was resolved in 9.62. C'est la vie.


Hi @cwaldrip

Thanks for this, I will try this next time I have to image a fusion drive device, I expect to have to image one soon.
If this works, I might write a simple script to run manually before I reboot the device.

If this has been fixed in 9.62, I have not noticed, as I have not had to image any more fusion drive devices since last.

- Sean

Valued Contributor II

@cwaldrip thank you for bless command. fixed(worked around) my issue!

Contributor III

One of the Techs somehow managed to mangle a machine with a Fusion Drive.
When I run the command diskutil cs list I get in response "No CoreStorage logical volume groups found"
Disk Utility shows 1 TB drive split into 2 500GB chunks with one named "Free Space"
How can I fix this?

Valued Contributor II

Well, I found a CNET article that walked through it, the downside is that I didn't save the link.

Theoretically if you google "CNET How to make a custom CoreStorage drive in OS X" (something) that may lead you to what you need. If you don't find it, I will paste the whole article in.

Contributor III

Thanks @jwojda just what the Doctor ordered

New Contributor

I have been using the following script on this page

and it has worked with all our new macs that came with fusion drives.