is already scheduled for management.

New Contributor


I am trying to deploy some apps to our school iPads however one iPad keeps spitting:

"app* is already scheduled for management."

This has been happening for a week. Is there any fix?


New Contributor III

I worked with JamF tech support and their suggestion of turning off cache servers (use apple for app updates) and have the apps set to "not" update automatically seems to reduce the dreaded "scheduled for management" issue.
JamF tech support stated the since our environment had iOS from 9.x to 10.x, there would be issues with the cache servers.
I am in the process of getting all our iOS devices to 10.2.1, removing the older iOS devices that can't do iOS 10.x, then I can turn on the cache servers again.
I am also hoping that Apple will release iOS 10.3 soon that can fix these issues.

my 2 cents

Contributor III

Ugh. We had HUGE issues with not having ENOUGH caching servers this fall when school started. We had to deploy 5 new caching server to get apps to install!! What a mess.

New Contributor

Having issues too

New Contributor

We are currently having this issue with a single user and a specific app.

Is there a resolution to this?


If there are other Apps that at stuck on Loading, press one to pause and press again to start loading again. Finally my Self Service app started to come down as well. Issue: The app “com.dreambox.dreamboxmath2” is already scheduled for management

New Contributor II

I am having the same issue with a single user/iPad and one specific app. Other apps will install just fine on this iPad and this app installs on other iPads. Has anyone found a solution?

Release Candidate Programs Tester

I have had this on many different apps and it appears to happen at random a solution that I just tried twice today was I went into the App Store found the app and noticed it was trying to install there. I stopped the app from installing in the app store and then went back to self service to install and it installed without errors.

Valued Contributor II

I fixed it this way once myself last month. All our apps are device assigned.

I have an iPad Loaner coming back in today with the problem so I'm going to collect some logs for Apple Enterprise Support..

New Contributor

We have this happen on a few iPads every time we push an update. The only solutions I found is to send a remote reboot command, then it installs just fine.

New Contributor III

We've been seeing this problem pop up more frequently now. I've tried the majority of what is suggested in this thread and performing a backup and restore has worked in past. Today, I got stubborn and decided to troubleshoot further. I thought of one other thing I hadn't tried. We have the Appstore blocked on our iPads, so first thing I did was take away that restriction. Then I searched for Pages in the app store and clicked the install button. Once it asked for the apple ID, I just hit cancel (since our apps are scoped device based) . I went back to the home screen and sure enough, pages was showing there greyed out now. It let me delete the greyed out Pages off the device at that point. I did a refresh from our JSS and Pages began installing successfully at that time.

New Contributor III

I just had an iPad brought to the shop with this issue. I was able to fix it with andy.cauble's procedure. Thanks!

Contributor II

We fixed this issue on ours with the same solution andhy.cauble used... we just installed the app through the regular app store (it just needed to show up on the ipad). Then we deleted it and it installed normally from the JSS.


+1 for @andy.cauble His process worked for us as well. Thanks.

New Contributor III

andy.cauble's suggestion worked for me just now! +1

New Contributor II

I fixed the same issue with solution andhy.cauble. Thanks a lot. CCA rules)

Valued Contributor III

This thread is an older one with newer posts so I'm going to appropriately update it with what I've learned today.

I was facing the same issue with "app already scheduled for management" on a student device.

Background: all student devices enrolled with DEP using device-assignable VPP for app distribution. The App Store is permanently closed to our students. I have this issue occur, but it occurs very infrequently (about once a month on one or two devices randomly...we have a large fleet of 6000). I have previously found that very little seems to fix this issue. Occasionally a reset settings and an update of the iOS fixes things but nothing that I can turn to in a pinch.

Decided after it happened today and I had time to file a case with jamf on it. Here is a snippet of what they sent me:

1. Jamf sends an InstallApp command, device acknowledges the command. After this, there is no interaction with Jamf for the actual download/install. 2. The device reaches out to wherever it gets the app from (either vpp app store, public app store or caching server) and then installs what it is told 3. In these types of scenarios, there is usually something wrong with the app file that it downloaded (again, outside of Jamf) 4. This causes the install to fail. After the install failure, the iOS holds on to certain remnants of the app which are left in an "unmanaged" but "scheduled for management" state. This leaves little room for Jamf to do any corrective action since we can only do things for managed apps. 5. The cause is between the device itself and where is gets the app from. One thing you can try would be to download from the app store on the iPad itself. This could install the app correctly and then we can use Jamf after the fact to "make unmanaged app managed" in the app record.

I will be honest, they also sent further suggestions which I don't want to get into because I feel your Jamf rep should be involved if you try to perform them. That being said, I took this knowledge and performed the following...I temporarily lifted our App Store restriction and used a hidden Apple ID I maintain with all of our purchased apps on it, installed the app by hand on the device, deleted the app, made sure the App Store and iCloud were logged out and re-applied the purchase restriction.

I then reinstalled the app from Self Service and it completed on each of my afflicted devices.

In short, definitely not an end-user-facing fix, but I can easily train technicians to complete this fix. Hope this technique helps someone...if not contact your rep as they do have techniques that higher level engineers at Jamf can consider performing.