iSight Cameras not working on current version?

New Contributor II

Anyone else experiencing this, or can offer some advice?

Our config profiles allow the use of the built-in camera, however currently (even on the latest macOS versions) they're not working on any software, see screenshot.

They were working fine then last week suddenly started getting error messages!

Any suggestions on potential fixes?



Honored Contributor

Contributor II

Try an SMC reset?

Turn off the mac unplug everything put power. When off hold down Option+Control+Shift and tap the power button a few times. Then turn it back on.

Valued Contributor II

We just had this same problem. We had a configuration profile that set the screen lock time after screen saver or display sleep begins. Even though this profile did not restrict the use the camera, it was the cause of the issue. When we removed the profile from our Macs, the problem instantly went away. I was told by Jamf support that this is a bug that the developers are aware of.

Contributor III

Best workaround is to add 'Restrictions" with "Functionality/Camera Allowed" to any Config that has a "Security and Privacy" payload included.
Works without having to delete the config profile.

New Contributor III

"Best workaround is to add 'Restrictions" with "Functionality/Camera Allowed" to any Config that has a "Security and Privacy" payload included.
Works without having to delete the config profile."



New Contributor

Thank you very much. You saved us. I was going crazy. It was actually an Apple Care advisor that suggested it might be Jamf. You would think that Jamf would send out a bug alert.


FYI - The fix for this issue worked. Today we had some people reporting an issue with Touch ID. They were able to access the tech ID in System preferences but the check box for using it to unlock the computer is greyed out. We do not manage Touch ID at all. On a whim I edited the Restrictions that I used to fix the Camera bug and added to allow the Touch ID. As soon as I did this and applied it, it untreated the check box and worked.

Contributor III

This has been fixed in 10.6 and hopefully up

This one is tracked under PI-005793: macOS Security & Privacy payload disables Camera A fix for that PI has also been identified and is implemented in Jamf Pro version 10.6.

New Contributor III

I've just updated to 10.6.2 and am still experiencing this issue.
@tjhall I'm having trouble parsing what you're saying.

Best workaround is to add 'Restrictions" with "Functionality/Camera Allowed" to any Config that has a "Security and Privacy" payload included.

1) Find a Configuration Policy with a "security and privacy" payload 2) For that policy, under Restrictions -> Functionality, explicitly check "Allow use of camera"

Is that what you mean?

Contributor III

@echave It's my understanding that the issue is resolved with Jamf Pro 10.6. The issue might be that you need to push all the config polices again (make a minor change in the name for example) for it to be pushed out and take effect properly (it won't push out the fix just because you update).

Otherwise yes, find any config policy with a security and privacy payload and then set "Allow use of camera" (under "Restrictions" in the same config policy). In your case it shouldn't be applicable since you already upgraded.

New Contributor III

@tjhall Thanks for the response and clarification. Issue is still occurring, but not with any consistency I can nail down. At various times of the day the iSight will work as expected or declare no hardware found like the OP issue. My own machine is affected so now it's personal....
I've gone through all of the config policies that are the same between my machine and that of one of my users, explicitly allowed camera in all of the shared config policies that have a security payload, and pushed them back out.
I've noted the times when the camera is working (or not) and tried to correlate them in the management and history logs, but to no avail.
My best guess is a conflict between policies.

Contributor III

@echave Yes, that sounds like a clash. Since it's resolved in v10.6 you should be able to turn off the "camera allowed" and delete any added "Restrictions" from all your "Security policy's" and see how it goes.

New Contributor III

@tjhall Believe I have it isolated and resolved. Found two config profiles scoped to my machine and NOT student's. By looking in the Profiles section of System Preferences, I could easily see whether a restrictions payload was being applied for an individual config policy. Thanks for your help.

New Contributor III

@prodservices -- The fix worked for camera but it breaks Safari autofilling. 783956c543b2459290b6f3515493670c

Any suggestions please.