Jamf App Catalog Mac Apps not installing

New Contributor

We are installing some basic list of apps some from the App Store and some from Jamf App Catalog

In some cases Jamf App Catalog apps (Chrome and Google Drive) do not install.



These are brand new M1 Macbooks

Some apps will install (like Zoom) pretty consistently

Happens 10-20% of laptops

Persists over days


I tried  

- restarting the machine

- running a manual inventory update 

- running client reset (jamf recon || true; jamf manage || true; jamf policy || true)

- checking if installation is pending (not)

- reassigning the computer to the group for which the apps are installed

- creating a different deployment of the app for that specific computer


Any ideas?

N00b to Jamf, what logs can I pull to see what happened with app installations




New Contributor

Same issue here, any input would be helpful! 

New Contributor II

I've been trying to understand how Mac apps get installed and why they sometimes don't get installed. I'm making some progress with the first bit; not so much with the second.

As far as I can tell, the apps don't get installed using the Jamf process; they're installed by the appstored process as if they were App Store apps so looking at /var/log/jamf.log gets you nowhere. Looking at /var/log/install.log will show you the full process of installation but tells you nothing if the install doesn't work.

Using log show seems to give more useful info - eg

log show --last 2d --predicate '(process="appstored") && (eventMessage contains "Allowing start")'

scans the log for the last 2 days, looking for events created by the appstored process and with "Allowing start" in the message - you'll see one of these at the start of every installation.

What I haven't yet got is any indication of why the install isn't starting; Microsoft Defender is failing to install on quite a few machines so I've tried putting eventMessage contains "Defender" as part of the predicate statement but it finds nothing which I think tells me that Defender just isn't available to the machine (even though it's in the right Smart Group).

If you look at more of the log for a particular install (change the eventMessage part to include the app name - I looked at Outlook) then you can see all the steps. It downloads the installer from https://appinstallers-packages.services.jamfcloud.com

If you search for a particular computer in your jamfcloud instance and then look at Management History section of the History tab then you'll see "InstallEnterpriseApplication" commands for each application (but no info about what app is being installed). 

I'm going to keep digging - I know that Mac apps is still in preview so I'm hoping that eventually Jamf will publish some more info on how it works and, more important, how you debug it when it doesn't work.

Good luck :-)


New Contributor

Hi, I am also new to Jamf Pro.  I did come across, "In the weeds with the App Installers preview" by Emily who has a great writeup https://www.modtitan.com/2022/03/in-weeds-with-app-installers-preview.html 

After some apps didn't install automatically over the weekend, I toggled Deploy off then on.  It did eventually install the rest.



Seeing similar behavior.  Only using Jamf App Catalog one on specific system, with no apps installed.  It looks like the installd process stalls on some installers coming in from the Jamf App Catalog.  So far I've had this occur with Microsoft Word and Microsoft OneNote.  If you have multiple packages installing, in queue, killing the installd process can sometimes get you to the next package in line waiting to install from the catalog.

New Contributor II

I know we're on a two week old thread, but I'm also running into this issue. Install doesn't seem to be running, so it's not a stuck installer. It's just not notably trying to install any of my Microsoft apps.

New Contributor II

We're having the same issue with Chrome and Microsoft office apps, though zoom succeeds every time. Not sure what's going on here but it's a pretty terrible experience.

New Contributor

I could not find solution and it became more common. Stepped away from using jamf catalog

Valued Contributor II

I'm running into a similar problem with Chrome, with the updates.  Devices that had chrome apparently are getting their chrome deleted, but not getting the new version.



I continue to see inconsistencies as well.  I really want to use this new feature but it doesn't seem fully baked yet, for whatever reason.  What is the support policy for features in "Preview"?

I'm short staffed at both organizations I work for and this would definitely reduce the load for some tasks.  The Adobe apps included are actually working quite well at the moment (knock on wood) and that's a major time sink removed if we can use the App Catalog packages instead.


Heads up, looks like the most recent Adobe Illustrator 2022 package released to the Jamf App Catalog on 7/28/22 has problems.  Noticed that Adobe Illustrator has disappeared from the entire scope of systems that it was installed on via App Catalog.

I like the idea of continuing to use this thread to log problems, since this feature is in Preview, but also available in production environments.  Seems like the Bermuda Triangle of support options...|

UPDATE: It looks like the Illustrator package being published by Jamf fails on Apple Silicon, but installs on Intel.  Same Jamf App Catalog policy...


Ugh... so does anyone at Jamf technical support know about the Jamf App Catalog feature?  I opened a service request, and I was quite clear that I was having difficulty with a specific update in the Jamf App Catalog, and I got back a request from support to review the documentation for installing packages via policy (not applicable at all) and to provide error messages in jamf on what's failing (they don't exist in the current App Catalog UI but I already provided the adobe log from the system) and to review the Adobe error message documentation (I already did and said that in the ticket).

Is there a way to get stuff escalated to the next tier without sounding inconsiderate or rude?  I don't want be one of those people who are like "I've been doing this for over 20 years", but, I've been doing this for over 20 years.  I spent about 20 minutes providing what I expected were the details required to get support and I feel unacceptable initial response (given the details already provided) from the Technical Support person.  I don't often open Jamf tickets as I've been using it since version 6.x so I'm usually able to resolve most of my own issues but this is the first time I've gotten one of those "I read one word in the request so here's a bunch of KB articles that actually have nothing to do with your request" responses... and this is a cloud only/cloud hosted feature so my fix-myself options are limited now.

New Contributor

I can also verify that from my testing, the jamf app catalog apps (zoom, chrome, adobe acrobat, etc) install without issue on Intel chip macbooks but are failing on all of the silicon macbooks I am testing with.

New Contributor

@jwojda I've been having identical issues.

Users who have had chrome on their machine are having their chrome app deleted/unavailable on their machine. We typically have to manually reinstall these applications, despite Jamf pro reporting that their machines still have the applications and have have received the packages. 
Users with Apple silicon have been most affected by using the Jamf App catalog to keep their software up to date. However, users on intel processors are being affected as well. This is occurring despite Chrome being a universal processor application

New Contributor II

Anyone have any updates on this thread? As others have mentioned, Chrome and MS Office apps seem to stick nearly every time....


Jamf App Catalog continues to be unreliable in my opinion.  It's most likely the MDM commands and Apple's limitations on them that are causing the problem, so I'm unsure how much logic Jamf can build into the package install scripts that can accommodate the limitations to Apple's toolset.  I don't believe the original service/company that Jamf purchased that provided the basis for the Jamf App Catalog services used the MDM install enterprise application commands for installing the applications (but I could be wrong on that).

New Contributor

Jamf App Catalog apps are also not installing for me.
@jamf please help!

New Contributor

Unreliable here too. 

Existing device, and Jamf can see in App Inventory that appNameHere is not installed. However, the Jamf App Deployment says that the machine does have it installed.


The mac inventory won’t show the apps installed until a recon is done. The mdm install does not invoke recon. Have a daily policy for this or self service for the user. Then check installed apps. 

Manual recon done many times, no change :(