Jamf packages not found

Mr_Meaves
New Contributor

Just started the role and have been reading documentation non stop. I’ve successfully created and deployed chrome, BBEdit, and September’s security packages. Did this by adding the download into composer, convert to source, packaged as dmg. Then put that new dmg into admin, update info and save. Finally create a policy in Jamf pro. But when I’ve tried that on other items like Firefox and zoom, I get a failed package not found. I’ve confirmed I see it in the file repository. When I started I had packages built by the previous guy that did that as well, so I deleted them assuming he messed up somewhere. Is there something I’m missing? I’m trying to deploy via Jamf remote during testing.

 

First admin job, and trying to learn apple and Jamf all very quickly, so any insight would be appreciated or links to different  documentation on this specific area (packaging and deployment for Mac). 

thanks in  advance!

2 REPLIES 2

sdagley
Honored Contributor II

@Mr_Meaves Are you using SMB, or HTTPS, for your Jamf Pro Distribution Point? I've seen the behavior you describe when using an SMB distribution point when the file permissions on the uploaded .dmg or .pkg weren't set to allow any user to read. You might check that if you're using SMB. And if you are using SMB, please please please try and upgrade your DP to HTTPS as soon as possible. You'll find that using HTTPS is much more reliable (resumable downloads versus fail on 1st error with SMB) and performant (with HTTPS it's just a  transfer request, you don't need to mount the file system of your DP as with SMB)

Thanks, that makes sense. It is AFP and I’ve been trying to find
requirements to switch it to https. Talked with my security guy this
morning and we’re going to try it.