Jamf Pro 10.2.1 Maintenance Release

New Contributor

A maintenance release of Jamf Pro is now available. Certain scenarios with sites enabled impacted Jamf Pro performance when MDM requests were being sent. This maintenance release fixes that issue. Jamf works hard to ensure product quality and will continue to be open and transparent when product issues arise.

You can download the update installers from Jamf Nation in the "My Assets" section. If you have any questions about this release or anything else, please do not hesitate to reach out. For more information about Jamf Pro 10.2.1, please review the release notes.

Liz Beilke
Launch Manager



Does this release fix the Self Service crashing upon launch bug introduced in 10.2?

Contributor III
Contributor III

@krispayne Thanks for the question. This updated Jamf Pro release was solely around a fix for the one PI listed: (PI-005434) MDM Inventory Requests for Customers Using Sites Cause Significant DB Connection Contention. So it was around performance on clients using Sites and MDM. If you are having a problem with Self Service I would recommend opening a support case explaining the problems you are seeing.

Contributor II

Have many others seen this issue about Self Service crashing upon launch that @krispayne is talking about ? Makes me a little nervous about upgrading to 10.2.1.


I can confirm Jamf 10.2 and Yosemite is definitely an issue:


I haven't tested 10.2.1, but given that the release notes are 1 sentence long and do not mention this issue, I assume it is still a problem.

Valued Contributor

@rcorbin we are pretty much all on Sierra and higher and using Self Service 10.2 without any issues.

New Contributor II

I've was holding off on 10 because I wanted to wait for the bugs to be worked out with a few releases. I finally jumped in with 10.2 from 9.101.4 .CPU peformance took a hug hit. Self-Service was also completely unresponsive on iOS. Self-Service on Mac still worked. I ended up going back to 9.101.4 and I'm waiting for another big release to hopefully address those issues. Support has all my information with that incident on a case.

Contributor III

Currently have an open issue with JP 10.2 and self service on 10.11 and 10.12 clients.

Contributor II

So perhaps this isn't just Yosemite clients, but also affects 10.11 and 10.12 ? @Jason.Scott we updated to 10.1.x a while ago and it's been pretty good for the most part. Yes we have noticed to be a bit slower, but it is certainly usable. We were looking at moving to 10.2 yesterday when I noticed that it had been updated to 10.2.1. It was at the point that I read a few were having issues with Self Service. I'm not clear if this is just Yosemite or not, but we do have some Yosemite clients in our mix so this may be a show stopper for us. Bring on 10.2.2.

Valued Contributor II

After the 10.2 upgrade, I found that Composer 10.2 would not allow me to delete components while building an install package. I had to go back to using Composer 10.1.1. Is this problem fixed with 10.2.1?

Contributor II

It seems like after talking with support on Monday (when US offices were closed) that this was a known issue early and some cloud users instances were offered a patch. I attempted an upgrade to our on-prem cluster over the weekend, which I would've avoided if you were really "open and transparent" and had communicated publicly about the issue found. Instead the upgrade was unsuccessful as we faced the known (to Jamf) issue, PI-005434, and we had to roll back to our backup.

I really hope 10.3 can focus on stability, there are still some major bugs with core pieces like Recon which need to be addressed.

Contributor III

Is there going to be a resolution to Computer Management/Configurations not showing any packages that are selected since 10.1.0? The only way to see them is to use the JAMF Admin app. Kind of goes against a quick way to setup configurations in the JSS Web app. Bummer when we lost that one on the 10.1.0 update, went to 10.2.0 and it's still not showing.

Have a very great day everyone!

Contributor II

I have a random problem of Self Service NOT opening up for specific users, we are running MAC OSX 10.12.6 Sierra. We are running JAMF PRO 10.1.1 and I am hopeful that it gets resolved with upgrading to JAMF PRO 10.2.1.

Contributor II

@dmichels It sounds like 10.2.1 might be more problematic for Self Service. We are running 10.1.1 and haven't really seen any Self Service issues. It seems that 10.2.1 might have issues for Yosemite users, but @djdavetrouble posted that they are having issues with self service on 10.11 and 10.12 clients as well. Bring on 10.2.2 ?

Valued Contributor

I'm currently working with Jamf Support on this issue, seen in 10.2.0 and 10.2.1

New Contributor III

The Jamf 10.2 and Yosemite Bug has been good for us. Macs in need of an upgrade finally got one.