jamf recon stalls at Locate Hardware Information

New Contributor


I am curious to see if anyone else has seen this.   I have noticed since macOS Sonoma has been introduced, it seems that when it gets to Locate Hardware Information (macOS version), it would take a few minutes longer than I have seen before.   Now it seems to take about 5 minutes.   Is this something that is common?

Also, on the same area, when I do the recon command while off-network it would take about double the time.   I suspect that because our Macs are domain joined, it is trying to find the domain and the OU it belongs (in JAMF, the information for the MachineOU changes from its current OU location to "not valid") before it times out.

Has anyone else seen this?  Please note, I don't have access to change anything, I'm a tech that uses JAMF and reports anything. :)


Thank you!



@Couriant - I've faced this issue while collecting available software updates information during inventory collection. Try disabling that and see if it speeds up the inventory update without any failures. It's worth noting that we're using a customized macOS Software Update Workflow that doesn't require this information, so we've disabled it. If you need this information, please bear with the delay. 



Valued Contributor

Sweet... that worked for me (fwiw). I thought I had a bad EA somewhere and had been putting off troubleshooting.

Honored Contributor III

Domain binding macs does cause all kinds of issues, but generally Jamf itself should not care. Have you tried running recon with the verbose switch? There is a chance things are hanging on an Extension Attribute. Extension Attributes Just after the "Locating hardware information" section and running recon with the verbose switch will show the EA's being checked.

Legendary Contributor III

As @AJPinto mentions, you should run your recon in verbose mode, because the jamf binary is multi-threaded for some years now, so just because it looks like it's hanging on the hardware inventory doesn't actually mean that's where it's getting stuck. The verbose switch will reveal what its stopping on. Generally speaking, with the exception of the built in software update collection, which relies on the Mac being able to connect to an external service (Apple), most of the native jamf binary inventory collection options are fine. It's usually something we have added to the inventory that's the culprit, like an Extension Attribute.

New Contributor

Thank you so much for the information.