JSS syncs to ASM when set to never sync

marktaylor
Contributor

We are using Apple School Manager with JAMF to control our shared iPads successfully at the moment.

I need to stop the auto sync between the JSS & ASM and just use the manual option when required. I have an issue where the options in the JSS are both set to never sync but it still does a daily sync!

I cant have an auto sync because the JSS pulls in inactive records from ASM which causes duplicates.

Anyone else experiencing this or know how to correct it?

1 ACCEPTED SOLUTION

marktaylor
Contributor

Workaround received from JAMF
Thanks

Unfortunately this is a product issue in the current version of Jamf Pro where if a sync time was ever set up to anything other than "never" and then changed back to "never", the setting is no longer respected. For the short term, I recommend we set a sync time to be "once per month" When we do that, the daily syncs will stop. We'll then have to schedule a reminder in a month to change the sync day to a day in the month that has already passed.

View solution in original post

4 REPLIES 4

peter
New Contributor III

Which version of the JSS are you running? We released a fix to sync scheduling that went out with 9.96 that I think would address that issue.

If you're already running 9.96 and still seeing this then please reach out to Jamf Support so we can get a product issue filed.

marktaylor
Contributor

We're running JSS JSS 9.97.1482356336

Issue reported to Jamf but only suggestion was to uncheck " Enable Apple Education Support" but we need this for the shared iPads!

peter
New Contributor III

Thanks, I filed a new issue PI-003435. There is a rather inconvenient workaround . When you add a new ASM instance with the sync interval set to "Never" it will honor that setting correctly. So, you could delete your current ASM instance from the Apple Education Settings page and then add again with the sync interval set to "Never". I'd try this out in a test environment first since you'd have to reimport the classrooms and could end up with some duplicate classrooms.

marktaylor
Contributor

Workaround received from JAMF
Thanks

Unfortunately this is a product issue in the current version of Jamf Pro where if a sync time was ever set up to anything other than "never" and then changed back to "never", the setting is no longer respected. For the short term, I recommend we set a sync time to be "once per month" When we do that, the daily syncs will stop. We'll then have to schedule a reminder in a month to change the sync day to a day in the month that has already passed.