LDAP User Not displaying in JSS


We have been encountering an issue this year where some of our AD accounts are not displaying in JSS. Basically, we have a script that runs and pulls the AD user accounts into LDAP in JSS. We've checked the script and the only way it will not be reading it correctly is if the AD user account is not setup right. Well, we've checked and made changes to this particular AD account, but the user is still not showing up right when we go to do the LDAP user test in JSS. You can search for "local user accounts" under the computer search and it actually finds the exact MacBook the student is using, and even lists them as a local user account. However, it is not inputting the user information in the "Username and Location" field. I've manually input the data, however, it's still not pulling the AD Group Membership Query. This is actually preventing Faronics Insight to install on the user MacBook's with this said issue. From everything we can see, there should be no reason this is not working, as the same data we input is the same requirements we've done for other students and have had no issues...just this select bunch.