M1 Macbook in DEP only loading the 3 main Jamf Configuration Profiles after wipe/rebuild

Contributor III

We have a test M1 Macbook that is in DEP. Since last week it has only installed the following Configuration Profiles after a wipe/rebuild:
- Jamf Notifications
- MDM Profile
- Privacy Preferences Policy Control

I have a bunch of other Configuration Profiles that normally flood into System Preferences > Profiles as soon as a machine is enrolled. They are not going in.

The twist to this is that some time later (so far it's been overnight) the profiles come in. I've tried a manual database backup but that didn't trigger the profile deployment.

Our Server is Jamf Pro 10.26.1

The other issue I see is that in Jamf Pro > Machine record > Management tab

I just get a spinning circle which never ends. Other tabs are fine. I've tried this on Safari as well as my default Firefox which is the latest 85.0.2 I am on Catalina 10.15.7. So, I don't think this is some quirk of the browser. When the profiles do eventually deploy, the Management tab for the machine is accessible in the Jamf Pro server

This does not happen for any other machine I try but they are Intel machines

Has anyone else seen this?

Anyone have an idea of what to try?

I have a bunch of people champing at the bit to get one of these machines but if I can't manage them properly, I don't want to say go ahead


New Contributor III

Just thought I would chime in to say we've encountered this scenario today and this post was the only thing I found on the topic. Same 3 profiles, same version of Jamf Pro. I'm glad you noted these profiles deploy eventually so we'll wait and see if this also happens here. I'd love to hear anything else on this.

Update: We pulled that Mac out of the local office, took it home and had no issues with enrollment. The local support team came back to us a few days later to let us know there was "weirdness" with the local office network that likely caused the problem we encountered.


Are these M1 Macs re-enrolling to an existing computer record in the database, or are you deleting the old computer records before re-enrollment?

Contributor III

Hi @wmehilos I've actually been removing the inventory record for the machine and pulling it back to Apple School Manager for a few minutes and then reassigning it back to our Jamp Pro server in ASM. I've also been putting the m1 in DFU mode and rebuilding it using the Restore option in Apple Configurator 2. There is a Prestage enrolment that it then picks up on first boot. There are no configuration profiles in the prestage. I have a bunch of intel iMacs in a different prestage for some labs and they are intel machines from the start of 2020 and all the configuration profiles pour in for them. They however are on Catalina not Big Sur

Contributor III

So today the machine pulled down all the configuration profiles. My process was:
- wipe the mac by doing a restore on the machine when in DFU mode using Apple Configurator 2 and whilst that was happening do the following steps
- delete from Jamf Pro inventory
- unassign via Apple School Manager
- wait until gone in Prestage Enrolment
- reassign in Apple School Manager
- wait until it reappeared in Prestage Enrolment on Jamf pro and Device Status was Assigned
- tick the box to put the Mac in scope for the Prestage Enrolment

I did update the server to 10.28.0 the previous day.

Since then I have been wiping (restore) using Apple Configurator only - no record deletion or unassign in Apple School Manager. Everything has been working correctly. All the config profiles get deployed now. I'm mystified but happier.