macOS High Sierra installer attempting to run after successful install

Contributor III

Hey Jamf Nation!
I have an odd one here. I recently updated one of my users computer from 10.12 to 10.13 using the Apple installer from the App Store. Now every time the computer reboots, it loads some sort of partition/diskf867983eee3545a5aab0581f426e6cb9 where it tries to fetch the installer that i deleted after the upgrade worked. I've seen this issue talked about for a failed install, but nothing after a successful install. I've tried to hunt down this phantom partition or disk its booting into, but i cant seem to find it. If the user holds the option key and chooses the "Macintosh HD" drive the computer boots like normal into 10.13.

id rather not wipe the users computer, but it seems that's what ill have to do. Any ideas?



Hi @DylanMurphy,

Did you happen to try resetting the PRAM on it? I have had similar situations before and sometimes that fixes it.


Contributor III

Hey @tomgideon2003 I haven't tired that yet.... i should have!


New Contributor III

We have seen this too. There is a preboot partition that doesn't get unmounted. The Mac boots to it. Option boot and you should be able to choose your drive and boot to it.

Contributor III

@mcarver thats exactly whats going on, i do have the user holding the option key and choosing the right drive, but thats not really the long term solution i want to give them. The poster above said to reset the PRAM, when i get the computer back ill test that and report back.

Valued Contributor II

out of curiosity, check your start up disk in system preferences?

New Contributor III

Please let us know whether the PRAM is enough to fix the issue!

I encountered this yesterday, and wound up reinstalling High Sierra from Internet Recovery. I did not have to wipe the disk first, so the user's data stayed intact. I'd be happy to hear if there is a better solution than that, though.

New Contributor II

I've gotten about a dozen machines back this week with the same problem. We've been reinstalling High Sierra from Internet Recovery, which is... tedious. Not all of our machines fall into this loop, which is maddening. I've been trying to replicate it in our shop, and it always upgrades flawlessly for me :-/


We had the same for system updates 10.13.1 10.13.2 10.13.3. This comes again and again.
We did tell the users to boot to recovery, use terminal and delete /Volumes/Macintosh HD/macos Install Data/
then select startupdisk Macintosh HD and reboot. all is good then. But with a very large pool of imacs and macbooks we fear already 10.13.4.
Hopefully apple fixes this. We have also a similar, thinking even related problem with recovery partitions no longer beein usable. On APFS pure Volumes, so only pure SSD imacs and macbookairs are affected, recovery partition and diagnostic is no longer bootable.
Does someone have the same problem ?

New Contributor

You can go to the startup disk and choose the drive that you are on. You should see the apple logo in the top left hand corner. Just pick start up disk and make sure it is booting into the right drive. This worked for me. I think this was happening to me because my machine was trying to filevault but also update at the same time which cant be done.

Contributor III

@mbracco ill have to try that, but i was struggling to find the path to remove, thank you! @irobinso sorry to report, that didnt do the trick :(

New Contributor II

@Dylan_YYC ,

We have been having this problem as well, and the recent 10.13.3 supplemental fix brought it back.

For us, the culprit was an outdated version of Symantec Endpoint Protection. So here was my workflow:

  1. Reboot the machine while holding ⌘-R. Let go once the Apple screen comes up.
  2. Once the menu comes up, click on the Apple menu in the top left corner. Choose "Startup Disk."
  3. Click on Macintosh HD and choose "Unlock."
  4. Once the disk has been unlocked, choose "Reboot."
  5. Log into the machine, and update SEP via Self-Service.
  6. Once the app has installed, reboot the machine again.
  7. Run the needed software update from terminal: softwareupdate -ai
  8. Reboot again.
  9. Log into the machine to complete the install process.

This allowed us to jump from all version of 10.13.x to the most updated version without encountering the loop again. I'd look at all antivirus/dlp software in your environment and look for 10.13 incompatibilities.

Contributor III

Hey @tommrkr Thanks for the tip, however we don't run SEP here.

Legendary Contributor III

First time I'm seeing this thread. Barring some issue with High Sierra, which it could certainly be, it sounds like the boot volume isn't being properly blessed and on each boot it doesn't know it should start from Macintosh HD, or whatever the internal boot volume is named. If you hold down Option at boot, before clicking on "Macintosh HD", hold down the Control key and the up arrow changes to a circular arrow, which indicates it's permanently setting the startup disk to that drive. Select it and then hit Return to continue the boot process. See if that resolves it. The user will likely have to reboot or shut down and start up again to see if it worked.

Even if it does, still begs the question about why the blessed boot volume is getting lost and/or why that hidden install partition isn't being correctly removed after the upgrade. Seems like Apple really has a lot of stuff to fix with High Sierra.

New Contributor II

@Dylan_YYC , might be worth looking at other antivirus or DLP software in your environment. Anything you are deploying to machines that isn't 10.13 compatible but maybe came along with a machine upgraded from 10.12?

Contributor III

@mm2270 ohh ill try that. When i go into the startup disks option, its not there the only one showing in the proper boot drive. i agree, some work here needs to be done! @tommrkr it has been out in the wild for a while, maybe there is something on it thats causing problems. i just wish there was a log or something pointing to why!