macOS Monterey Error 702

New Contributor II

Hello Everyone,

When we try to update many devices remotely or manually, we get a warning like the one below. we did the necessary research for this but we could not find an uptodate and useful solution.

Error : ( error 702.)

Restarting in safe mode
first aid
Redownload the package
procedures have been tried. remote and manual result error is the same

Anyone want to make suggestions on the subject?

Screen Shot 2021-10-29 at 22.59.54.png


New Contributor II

Hi again, yeah we were able to identify the cause of the problem. we were getting this error due to a Conf profile restricting the disk. after editing the profile problem was solved. but thank you everyone for your advice 😊

View solution in original post



Hey @DRprofile ,

I haven't seen this error yet but for remotely and automatically updating our Macs I have a two step setup which works quite well.

  1. Via a policy the Macs download the full installer: /usr/sbin/softwareupdate --fetch-full-installer --full-installer-version 12.0.1
  2. The upgrade process gets initiated via a second policy: '/Applications/Install macOS' --agreetolicense --nointeraction --forcequitapps

This worked pretty well on our Macs so far, just make sure this runs only on Macs capable of Monterey (regex: (MacBook(10|9)|MacBookAir(10|[7-9])|Macmini[7-9]|MacPro[6-7]|iMacPro1|iMac(1[6-9]|2[0-2])),\d|MacBookPro1(1,[45]|[2-7],\d)  ) and that FileVault 2 Partition Encryption State is not Encrypting.

As a result of step two we get a No such file or directory error, as described in one of my former posts, but that seems to be just cosmetic.

New Contributor II


thank you for the feedback. We have the encoding you said and remotely we are getting the same error.

After opening the package and entering the admin password time appears as 3 hours 46 minutes and decreases to 3 hours but then the 702 warning occurs.

After completely deleting MDM on 2 devices and then restarting, I reinstalled the package and this time it started with 56 minutes. And as a result the device was updated. Strangely enough there are " 702 " alerts on a large number of devices. and something like removing MDM on devices is not even up for debate.

We are trying to find out what could be preventing this in the conf profiles. when we search for this warning on the internet, it is stated that the same error occurred in El Capitan and Big Sur.

and in addition when we try to open any DMG file on these devices where we receive a 702 warning we get a warning that it could not be mounted.

Valued Contributor

I have seen quite a few issues upgrading to Monterey. I had one myself that I had to sort out saying the hardware was not compatible (M1 MBA with plenty of free storage). Some of the solutions are to make sure the target Mac is fully updated before attempting to install Monterey.


However, in my opinion it is too early to bother with wide scale deployments or in place upgrades of Monterey. Let other people find the problems and let apple sort the kinks out. I will not be even attempting an in place upgrade to Monterey in any form of deployable fashion until turn of the year. Being an early adopter has always caused more problems than good from my experiences. 

New Contributor II

I too ran into issues upgrading several managed machines to OS Monterey both remotely and manually.  So far the only fix I've discovered for pushing the update is to:

  1. Navigating to Disk Utility
  2. Selecting the View All Tab
  3. Running first aid on each and every volume, container and disk in that order
  4. re-running the OS install
    This has worked on a few machines for me, though this is not ideal if you need to do this for many users at a time.  I'm still searching for a fix that I can push out that would make this solution a lot easier. 

New Contributor II

Hi again, yeah we were able to identify the cause of the problem. we were getting this error due to a Conf profile restricting the disk. after editing the profile problem was solved. but thank you everyone for your advice 😊

What exactly did you do with the profile to resolve? 

New Contributor

What does that mean and how do I do it?

New Contributor III

I'm seeing this across a few users when trying to upgrade from Catalina to Big Sur or Monterey. I've performed First Aid on the drive and have tried going through the command line and the GUI with the same result. We have no config profiles restricting the disk in any way. My next step is to try booting in Safe Mode to see the result.

New Contributor II

Alright guys I think I got this figured out.  To avoid the 702 error I went into Jamf > Configuration Profiles> Media and unchecked "require authentication" under Recordable disks.  After this I needed to restart the computer and was able to install the latest OS without issue.Screen Shot 2021-11-24 at 12.11.42 PM.pngScreen Shot 2021-11-24 at 12.11.58 PM.png Good Luck!

I appreciate the follow up - I've already done this and I still get the random 702 error, which is the problem, I can't find a connecting thread for all cases.

What version of Jamf are you running? I'm on 10.27 and don't see a Media option under Config Profiles.

New Contributor III

It’s under Restrictions > Media

New Contributor III

Thanks. All those options are already set to Allow on my end.

The key fix for me was unchecking "require authentication" under Internal Disks, external disks and disk images.  After be sure to restart your computer.

New Contributor III

I had a Config_Profile that blocked external drives.   Even though I un-checked "Require Authentication", I continued to receive the error...UNTIL I removed the machine from the Config_Profile altogether.  Works now.

New Contributor

Thank you! I thought I was doing something wrong, but finally found this article. I read through it, followed the advice, changed some settings, double checked that I didn't have conflicting policies, and now I am able to update.