Mavericks Image - Not Enough Space.


I created an OS X Mavericks Image for our 2011/2012 MacBook Airs using the latest 2012 model MacBook Air. Upon imaging a 2011 MacBook Air, I get the following error message: "Imaging "computer name" could not continue because there is not enough space on the disk." However, Imaging completes normally on a 2012 Air. Previous 10.8.5 images made with the 2012 Air work fine on older models. The SSD is being formatted and partitioned before imaging so there should be ~57GB of free space. The configurations in Casper Admin are exactly the same. Am I missing something? Is this a bug?


New Contributor III

How big is your Mavericks image?

Contributor III

Firmware upgrades are needed on a lot of the Airs for Mavericks. That may be the issue.


Mavericks Image is 15GB in total; all Firmware updates have been applied before wiping the drive out.

New Contributor III

I have used the following work around to resolve this for me. I had everything working fine in Casper 8 and the problem only appeared once we started using Casper 9.

I had a min install of OSX for a bootcamp MacBook Air and when I went to image it I got the same error : "Imaging "computer name" could not continue because there is not enough space on the disk."

This is my current work around:

- Created a new smaller partition on the MacBook Air, in my case it was a 10GB Partition and then restored the original image on it using carbon copy cloner.

- Created a new .dmg by using composer off the new 10GB partition.

- Uploaded the new .dmg to Casper Admin.

Everything imaged without any errors.


That worked, but you have to manually adjust the partition size on each individual machine after it's done imaging. It's not expanding automatically to fill the empty space.

New Contributor

Apparently this is a Mavericks issue. The Mavericks image was created on a partition larger than the partition you're trying to put it on. I tested my current partition setup using a Mountain Lion image and it works fine, even on smaller partitions.

I tried the suggestions in this article on my Mavericks iMac base image created with Composer and it didn't help. The response was "Volume format does not support resizing".

One suggested workaround is to recreate the image on a smaller partition that the partitioned hard drives can handle. I may do this to save time and get my employees imaging, but this is not a permanent solution. Anyone have any ideas on this? Could something be built into Composer to handle Mavericks when the partitions are smaller?

Thank you.

Valued Contributor

Yep dgraham is correct. re-sized the partition on my test machine, re-ran composer, image works

New Contributor III

I think this feature request would help make this easier.


I ran into the same problems. After re-creating the .dmg file with superduper, it worked directly. So apparently this issue is related to DiskUtility or Composer.