missing Jamfcloud packages in Casper Admin

m3ir
New Contributor III
New Contributor III

Hi ,

I've set local Distribution point on our jamfcloud environment , all seems fine beside all packages that exists on cloud shows as missing in Casper Admin , scrips shows fine tho .
is there any fine tuning need to be done?

Regards,
9543dc13f9ce445284d98991fa1386c2

9 REPLIES 9

m3ir
New Contributor III
New Contributor III

when I remove the local distribution point , all back to normal and nothing shows as missing .
now I wonder , casper admin shows cloud distribution point or local distribution point files at once and the rest as missing?
it can't mount both distribution point and this is why it shows as missing? in other words , this is normal behavior of casper admin?

thanks,

kowsar_ahmed
Contributor

What is your 'master dp' and which DP did you upload the files too? Have you completed a successful sync yet? The red indicates that the packages are missing on the master DP.

MacKae
New Contributor II

Any resolution for this?

geoff_widdowson
Contributor II

I'm having similar issues. I migrated to Jamf Cloud last week. I have my existing AWS cloud DP (not planned on moving to the included Jamf Cloud DP just yet), and I am uploading packages. After I replicated to my on prem file shares the packages started to show as 'missing', but if I switched my master DP to an on prem the packaged did not show as missing. I don't undertsand how the cloud DP can be missing when that is the DP I uploaded them on. I am now havign to replicate to the cloud when I have on prem set to master. I want my cloud DP as master at the moment as all my users are working remote.

VintageMacGuy
Contributor II

For those having similar issues, I was able to resolve mine by upgrading to the current version of JAMF Admin.

Sign in to Jamf Nation, Go to your Profile Picture in the upper right, go to My Assets, Download JAMF Pro. The DMG will have a folder with the JAMF apps in it - including the latest JAMF Admin.

Once I opened it and signed in, my apps showed up as not missing anymore.

sdagley
Honored Contributor III

It's pretty much a requirement that the version of Jamf Admin you're using match the version of your JSS (I thought there was a warning if it didn't, but maybe I'm imagining that)

scottb
Honored Contributor

@sdagley - there is a warning if you are off too far in either direction. But, say your cloud is 10.29.2 and you have Admin 10.29.0, I believe it still runs OK...

sdagley
Honored Contributor III

@scottb You may be right that as long as the JSS version and Jamf Admin version match for the Major and Minor fields, and differ only for the Patch field, it's ok to have non-matching versions.

Since using a version of Jamf Remote that didn't match the jamf binary used to do Very Bad Things™ (the Jamf Remote version check FR isn't closed so it may still be a problem) I prefer to update all of my Jamf apps as soon as my JSS is updated.

scottb
Honored Contributor
I prefer to update all of my Jamf apps as soon as my JSS is updated.

100%, but letting those above know that you can fudge a bit if you're in a bind...