Mojave policy banner weirdness

jtrant
Contributor III

Hi all,

Has anyone come across policy banner weirdness in Mojave where the user either sees only part of the text or just a blank window? We've had the same .rtf policy banner in place for years without issue, but in Mojave it's consistently misbehaving.

I have tried enlarging the window in TextEdit before saving, adding line spaces and changing the text justification to no avail. Other than just going with a plain text file, I'm not sure what else to try.

Any ideas would be appreciated!

Justin.dccfbfb75a074c6ab70ab04bccb70d3c

22 REPLIES 22

jtrant
Contributor III

Am I the only one seeing problems with the policy banner? If so, I might need to dig deeper.

Thanks,
Justin.

MacSysAdmin
Contributor

Nope been broken since the early betas.

jtrant
Contributor III

Ok, at least it's not just me. Thanks a lot for the confirmation!

nvandam
Contributor II

Nope, us too. And it's hit or miss. No rhyme or reason to it. I thought maybe external monitors were messing with it, but I can never replicate it. 17bc165219fe4df5b4918e401d5d15f5
94e553a9db864018bad122caafbee7d4

jtrant
Contributor III

Thank you both for the validation. I found mine aligns vertically just fine but I need to scroll left/right to see the text. It works fine except for a cold boot, e.g. log out/log in works perfectly.

dgreening
Valued Contributor II

I resorted to including an image in the rtfd of the text / graphics instead of the text itself, as the formatting kept getting borked.

jtrant
Contributor III

Now there's an idea, I'll give that a try!

jameswaltrip
New Contributor

It usually happens at a reboot and not at a logout / login. I tried the screenshot of the text and logo and that worked for a while but I'm still seeing the same scroll left and right within the policy banner. Mojave has a different format for .rtf. It's .rtfd so I guess that has something to do with it.

jimd
New Contributor II

Ran into this problem today. Anybody figure out anything further?

BTW... RTFD (Rich Text Format Directory) is not a new format. It's an RTF (Rich Text Format) file with attachments. If you right-click one and choose "Show Package Contents", you'll see your .rtf file, plus any pasted graphics. It's a bundle, just like an app, or an old non-flat package, or a KEXT. TextEdit automatically uses this file type when you paste a graphic into a document.

gersteina1
New Contributor III

The fact that it's not just my campus gave me hope, but seeing that it's been an issue without a fix since 2/2019 dashed all of that. Anyone seen any progress in Catalina? I haven't had any issues with my test computer, but it never had the issue to start with.

georgecm12
Contributor III

Catalina seems to display an oddly narrow Policy Banner window compared to previous macOS versions, but so far in my limited testing, it does appear to display the contents properly, unlike Mojave.

theguvnor
New Contributor III

@georgecm12 Indeed, I'm experiencing the same thing and am wondering if the new, smaller and narrower banner window is now simply a 'feature' on Catalina.

I first came across issues with banners in, I think, the second Beta, where, once the file was in place at /Library/Security/PolicyBanner.rtfd and the permissions were set, upon restarting the startup hung around 2/3 through the progress bar and never got to the login window. Remotely deleting the file and restarting allowed it to start up as normal.

From Beta 9 (Build: 19A573a) onwards it no longer caused the hang at startup for me, but, as you are experiencing, truncates the size of the banner window so it no longer looks like the example shown at https://support.apple.com/en-gb/HT202277 but rather is about 3/5 of that original size (which looks to have previously been A4) and forces the content to be scrolled.

I put all this in feedback to Apple throughout the Betas but never heard anything back 😞

NightFlight
New Contributor III

Yes, its now using a fixed size which is really too small.

EddyLara
New Contributor II

Hello, How can I insert my Company logo to the. rtf file. Please help

georgecm12
Contributor III

@Eddy72 You have to create an "Rich Text Document with Attachments", or RTFD. It's a bundle that contains the RTF file along with all the images. You can create the RTFD with TextEdit.

EddyLara
New Contributor II

Thank you George

CDAdmin
New Contributor

has anyone gotten/found a fix for this? we're trying to implement it here and the window size itself doesn't fit to screen

georgecm12
Contributor III

My solution was to do what @dgreening did above, switch to an RTFM file that only contains an image, no text. That seems to be the only thing that works 100% for me.

More detailed instructions:

  1. I created an InDesign document that was 6.5" by 6" with no margins. (I could have gone longer than 6" had I had to, but didn't need to. It also plays it safe for smaller screen sizes.)
  2. I laid out my text and the graphics I wanted to use in the InDesign document.
  3. I then exported it as a PNG, with the following options selected in the PNG Export dialog box: Quality set to Maximum, Resolution set to 300 ppi, Transparent background enabled, Anti-Alias enabled
  4. I created a new document in TextEdit. I dragged in the newly created PNG, centered the image, then saved the resulting document as PolicyBanner.rtfm.

The result is a little small on some of our screens, but again, it plays it safe so that I can use the same Policy Banner on all of our machines, whatever the screen size/resolution is.

zinkotheclown
Contributor II

I also did what @dgreening did but instead of InDesign, I created a 1265x784 document in Photoshop.

rpayne
Contributor II

How are you all getting the logo image to stay? I get rtfd in textedit, BUT when I try to add the image there it's huge and I can't resize. I understand this is very basic and I should feel stupid.

ajc196
New Contributor III

I just deployed a policy banner to 600+ machines, and within two days I have at least one report of a blank policy banner on Catalina after it worked for the first day. As far as I know, all other machines are working fine so far.

I created and deployed an RTFD with the permissions set per Apple's documentation. I used a 12KB PNG logo at 853x147 res, plus a couple small paragraphs of text whiteout any fancy formatting.

Had one of our user support guys delete the policy banner file and drop a new copy of it back in place, no difference. Policy banner still blank.

Is there any known issue that ever got documented on this, or is it just a random bug that I'll never really get to the bottom of?

sheltond3
New Contributor III

We currently use it with all 2000 of our devices, Mojave, Catalina and Big Sur alike. My recommendation is to follow these steps:

How to set up a policy banner in macOS

Another step I'd add though is to make your policybanner.rftd, take a screenshot of everything in it, then make a new policybanner.rftd file to replace it with and only have the screenshot of the first one in it. Essentially, its the only way i've found to make sure that all the text and images you want to show don't get pushed off the window or need a scrollbar on all the random sized windows that everyone has at home in this world of remote workers.

(Similar post here with same answer.)