Mojave Upgrade - error -69854


What’s up! Hoping someone can help here.

So we’re running a policy in JAMF via Self Service using the kc9wwh/macOSUpgrade upgrade script to upgrade our iMac 5ks running Sierra (10.12.6) with Fusion Drives to Mojave (10.14.6). We get hit with this when users run the policy themselves:

"macOs could not be installed on your computer. The operation couldn't be completed. ( error -69854.) Quit the installer to restart your computer and try again."


At first we thought is was something to do with the way the script was configured, so we tried it manually by just copying the macOS install app to the local Applications folder and double clicking from there. No good. Same error. We’ve tried everything suggested to repair based on the fact that this is some kind of disk error. But all the usual steps with Disk Utility don't seem to be working. And the only way out of this is to reinstall the previous system. Or wipe the disk we guess. Anyone else by chance ever seen this error?