New retina mbp does not netboot to our server!

New Contributor

Hi everyone new to Jamf but loving it so far. Little background: We currently have Casper setup (latest version) on our network and it has been running for about 6 months with no issues. I have been able to net boot our machines (both 10.6.8 and 10.7.x) with no issues. We just received the new retina mbp and it will not load the Casper net boot utility. When I boot holding down the N key the globe comes up and it acts like it is connecting but after the smaller globe spins the apple logo just sits there and we cannot do anything except restart the computer. I believe that we need to create a new net boot image but am having trouble finding info on doing this. If anyone has any suggestions please throw them my way!



Valued Contributor III

Yeah, I see the same thing with the new Air models. I am simply waiting to rebuild our base images with 10.7.5 and 10.8 and then we will make a 10.8 Netboot image. We have several dozen sites around the globe, so propagating new images takes so long it's not worth it just for a month or so.

In the meantime, I set up a configuration with all of our packages but no base image, so deployment techs just start up the Mac, set up the local admin account, copy Casper to the desktop, and run that configuration.

This gives us the same result as a complete image, and supports any hardware immediately. Every single thing we do is package-based, giving us this sort of flexibility.

New Contributor

I fixed the problem using the following steps to get a installESD.dmg (this is 10.7.3 when I downloaded last week) for the Mid 2012 MacBook Pro.

Then you using this installESD.dmg to do a inplace upgrade of your previous net boot image or other base image, then using Target disk mode to boot using the new Macbook hardware update to latest apple updates which will update the OS to 10.7.4.

Finally, you need to fix the settings which may vary depends on your environment. We have to apply cannon printer drivers as we use FujiXerox docucenter.

Good Luck.

Contributor III

We had the same issues here. Threw us for quite a loop since our image was up to 10.7.4. But when we go our new machines in they wouldn't boot up with the image. So what I ended up doing was booting a new machine up and setting up the base OS on it. I then captured it to another machine using composer and used that as a base for our image.


We actually made a 10.8 Golden Master Netboot. If you have access to them that can buy you even more time since it should hopefully boot the 10.8 machines when they start shipping.

Esteemed Contributor III

We didn't need to update our 10.7.4 (11E53) NetBoot server.

We grabbed a new MacBook Pro (Retina, Mid 2012) and followed the JAMF articles:

We tried to push back so we can wait for 10.7.5 to be released but we were we had no choice but to create (1) image for the Retina and (1) image for the 15" standard. Of course this meant creating Base Image, Restore Image and NetBoot Image (NBI).

We haven't set up a 10.8 server yet, that's next on our list...probably will need to wait though, until 10.8-only models ship.

PITA....PITA....PITA.... :)



Contributor II

All of this would be vastly simplified if JAMF would update their netboot image creation tool to work with 10.7+. Just sayin'.

Deploystudio's assistant/wizard used to let me update my netboot image in about 30 minutes. All I had to do was launch the assistant on the new hardware, and choose to create a netboot set. The wizard then automatically created a ~2GB image that I could plop onto my server. Mission complete.

InstaDMG solves the problem of having to recreate the base image from scratch, as all you need to do is grab the latest InstallESD and use it in place of whichever BaseOS image you used before. Run the script, all done.

Image creation, both netboot and base, is an area where JAMF is severely lacking, IMHO.