Paused for authentication - installing printers through Casper

jonlju
Contributor

Hello,

We have changed out print management system and therefore I had to add a new printer to Casper Suite. The system is set up in AD using a .gpo and a printerpool. I did this simply by adding the new printerpool to a Mac and then added it in Casper Admin.

While this works (the drivers are still the same), when the new printer has been added to a Mac through Casper, it will now say "Paused for authentication" whenever I try to use it.
If I add the printer the conventional way to the Mac, it will send the print without issue and I use my card at the printer to retrieve it.

Is there any way to get around this issue or atleast prompt for authentication details? Right now it just looks like the print job gets stuck in the queue and you have to "refresh" it manually to prompt for credentials.

Thanks,

J.

2 ACCEPTED SOLUTIONS

davidacland
Honored Contributor II
Honored Contributor II

I seem to have more success adding the printer via lpadmin with commands similar to lpadmin -p "servername" -E -v "lpd://address" -P "/path/to/ppd" -o printer-is-shared=false -o auth-info-required=negotiate. You can send the command via a policy to add the printer instead of capturing it via Casper Admin.

View solution in original post

jchurch
Contributor II

here's what works for us:
system preferences>Printer&Scanners>Add Printer window
right click on the tool bar and choose "customize toolbar" > add the Advanced button.
under advanced set the printer type to "LPD/LPR Host or Printer"
leave device at "Another Device" and enter the url of your printer lpd://printserver.yourcompany.com/printername
choose a display name and location for your printer and choose the appropriate driver and click "Add"
now capture the new printer with casper admin and make sure to save.
then go into the JSS > Settings > Computer Management > Printers
and choose your new printer. go to the Definition tab and choose edit. uncheck the "Use generic PPD file" and hit save.
now you can deploy that printer with a policy using the printers payload and your users wont be prompted for credentials when they print.

View solution in original post

8 REPLIES 8

davidacland
Honored Contributor II
Honored Contributor II

I seem to have more success adding the printer via lpadmin with commands similar to lpadmin -p "servername" -E -v "lpd://address" -P "/path/to/ppd" -o printer-is-shared=false -o auth-info-required=negotiate. You can send the command via a policy to add the printer instead of capturing it via Casper Admin.

View solution in original post

jonlju
Contributor

@davidacland Thanks David, this works fine on my test computer. Unfortunately I have to omit the auth-info-required string which seems to be due to the printing system itself. For some reason, even if providing the AD-credentials the first time when printing, the printer job will be "lost" when trying to retrieve it from the printer.

I have to instead manually change to my AD-username in the printing properties (it uses the full name rather than the username by default) and that means that while it looks like the job is sent successfully to the printer, you can't retrieve it when at the printer.

It's a bit annoying but atleast the printer gets added correctly now!

jonlju
Contributor

I should add that if anyone has a way to solve the authentication issue, any tips would be much appreciated.
While it's no longer that much of an issue since we changed this manually for all the Macs, it would be nice to have a better way of doing this.

The "solution" (more of a work-around really) basically was that we changed users "full name" on their Mac to their AD user name instead.
This way the printer receives the correct credentials straight away.

jchurch
Contributor II

here's what works for us:
system preferences>Printer&Scanners>Add Printer window
right click on the tool bar and choose "customize toolbar" > add the Advanced button.
under advanced set the printer type to "LPD/LPR Host or Printer"
leave device at "Another Device" and enter the url of your printer lpd://printserver.yourcompany.com/printername
choose a display name and location for your printer and choose the appropriate driver and click "Add"
now capture the new printer with casper admin and make sure to save.
then go into the JSS > Settings > Computer Management > Printers
and choose your new printer. go to the Definition tab and choose edit. uncheck the "Use generic PPD file" and hit save.
now you can deploy that printer with a policy using the printers payload and your users wont be prompted for credentials when they print.

View solution in original post

jonlju
Contributor

Excellent solution jchurch, this has worked with "Paused for authentication" error as well, thank you!

JimRevo
New Contributor

Awesome, this helped me get rid of the Authentication issues, but setting up the printers this way, how can I get the color printer to print in color? I have them configured on the Windows Print Server but I think adding Printers, as above, still cant get them to print in color.

areiskis
New Contributor

Thanks jchurch for this. This is working for us for a virtual follow you print queue that we had struggled deploying for a couple years now.

matthewconlon
New Contributor

Awesome jchurch - thank you for the quick guide.