Preparing an Apple TV 4k with Apple Configurator 2

New Contributor III

I'm trying to follow this handy article provided by Apple ( to add an Apple TV to DEP via Apple Configurator 2.

I'm able to pair the Apple TV then erase it, when the device comes back up Apple Configurator 2 indicates that it's waiting for the device. I waited for 15 minutes or so and there were no changes, so I figured the device needed set up and paired before being prepared.

So I tried that, but it just gets me back to the point where the Apple TV needs erased again.

Does anyone else have any experience with this?


New Contributor III

I am also currently running into this issue as well. So far I have been unable to enroll the device in DEP.

Valued Contributor II

Is this a question about enrolling an ATV 4 while directly connected to AC2, or while over the network? We've not tried over the network, we used USB cables (and it was the ATV 4 previous to the 4K).

Is your ATV connected to ethernet? Do you have it in a PreStage so it can get the settings?

New Contributor III

@cdenesha This is over the network. This is the 4k model. Yes it's connected to the same network via ethernet that our Apple Config 2 computer is on. The prestage could be the issue. I'm not seeing it there. I'll troubleshoot that and try again.

New Contributor III

@walts.9 I did find a solution for this Here. During the Apple Configurator 2 setup of the Apple TV it will be added to the "Devices Added by Apple Configurator 2" MDM server on the Apple Business Manager website On that site you can then migrate the device from the Apple Configurator 2 MDM server to the MDM server you have setup with Jamf for DEP.

Valued Contributor II

I have discovered a few 4K ATVs that were purchased third party. I was able to get ONE of them into DEP, but the next one will NOT show up in the main AC2 window.
Activate manually, go through setup, then Wipe ATV.
After ATV starts up
Without touching the ATV remote, I connect the ATV to my laptop (Big Sur) running AC2 v2.13.3, using ethernet, and successfully pair the ATV with my computer, but after pairing it never shows in the main window.
Anyone have any tips?
Currently running the TVOS update to see if that does it. zzzzzzzzzzzzz

Contributor III

In my environment after successfully pairing, the ATV almost never shows in AC2 main window. The workaround I found is to toggle the wifi connection on my laptop and instantly the ATV appears.


Just an FYI on Apple TV's and Apple Configurator enrollment, if you do a erase all content and settings on the device, make sure you DO NOT touch the remote for the setup process until it is fully enrolled.

My steps if the Apple TV is playing up is do go through and erase etc to factory settings whilst connected to ethernet via a hub to my mac, one its completed I do the rest via apple configurator.