Printers disappearing macOS 10.14.6

New Contributor

Over the past few months, I've had a few users in my organization experience a problem with their printers disappearing. All of our printers are network printers with static IPs. For some reason, the few users attempt to print and find out there are no printers to choose from. The users are on macOS Mojave 10.14.6. I'm unable to figure out what the problem is, however, I have read to reset the printing system. I'll attempt that but I'd like to know if anyone had an idea of why the printers are disappearing from the users laptops?

Any help/pointers are greatly appreciated!



We saw this also in the past. Updating from 10.13 to 10.14 did remove all printers from all computers in our park.
Updating from 10.14 to 10.15 did again remove all printers again, even though we tested it in lab without having that issue.
Now 10.15.2 to 10.15.3 did again remove the printers. As logs are cleared from /var/log/cups i have no trace of whatever happens here. Adding printers to hundreds of machines is not funny. If anyone has a hint, or a scenario to prevent this, would be cool.

New Contributor II

anyone find a solution to this .... I have a fleet of Macs running Mojave "10.14.6" and they are all losing their print settings... To boot when I attempt to add printers manually by going into System Prefs - Printers and Scanners nothing shows up after adding , same result when I push print settings via policy . the kicker is that when I take a look at " ~/.cups/lpoptions " the printers I configured do appear, and I can send print jobs to them , however they just don't appear in Printers and scanners - I've deleted all CUPs config files, and reset the print system via System Prefs -> printers and scanners and still no solution found - Printers just don't show up in Printers and Scanners.... Looks the like issue is still alive in Catalina which really worries me ... Need some help here - Might this have something to do with the print config portion of my Jamf managed printers payload ? That's what I'm beginning to think - just unsure - guess I'll test -

New Contributor

I've had something similar happen under Mojave with an alternative MDM and with PaperCut installed. Print queues randomly disappear and accessing "Printers and Scanners" locks up System Preferences. Also, attempting to choose a printer in the Print dialog box causes that process to lock up. I do not know the underlying problem but have, so far, been able to resolve this particular issue by booting the device into Safe Boot mode (hold shift key down while rebooting), then booting again normally. I have to first use Recovery mode to disable the firmware password. After these reboots, the print queues return and there is no more locking up when attempting to print or access Printers and Scanners.