Profile Error 0x7fff8b2300e0

Blake_smc
New Contributor

I am getting the following error when Jamf tries to push a newly created profiles using the "ProfileCreator" app from Github

-[__NSCFConstantString objectForKeyedSubscript:]: unrecognized selector sent to instance 0x7fff8b2300e0

Each of the profiles is to force private browsing for Safari, Firefox and Chrome. I had created a single profile but after seeing the error split them into seperate profiles to try and work out where the issue was.

8 REPLIES 8

user-TQBbiKviDD
New Contributor II

Got the same after upload a Jamf Connect config that I created with the Config tool. I tested the settings with the test section on that tool and works perfectly.
I don`t understand why I am getting this exception error

mainelysteve
Valued Contributor

Have either of you tried applying the profile directly on a device vs mdm delivered. That will determine if the profile you have is installable. Also was the profile signed before you exported it from Profile Creator?

Harrie
New Contributor III

I get the same error, and also I don't see a Microsoft authentication screen while logging in @mainelysteve I uploaded a plist, nothing to sign, not sure the poster did the same

JosephRecendez
New Contributor II

@Blake.smc did you ever figure this out? I am getting the same error when pushing a profile from Jamf ceased with the same tool.

fulltimecasual
New Contributor

Same issue.

mrgarcia
New Contributor

I am also getting this error when I upload a mobileconfig file from Crowdstrike.

mainelysteve
Valued Contributor

So I guess to reiterate my previous post. What is the end result of attempting to GUI(no mdm) install these profiles on a client?

whiteb
New Contributor II

+1 for having this issue as well.

Using the latest version of ProfileCreator (Version 0.3.3 - the Big Sur compatible beta one) to create the config profile.

Getting the following error when attempting to push the config profile with JAMF Pro: 

 

 

<Exception> -[__NSCFConstantString objectForKeyedSubscript:]: unrecognized selector sent to instance 0x1f48d05e8"

 

 

 Config profile isn't signed because I couldn't immediately figure out how to sign it with Apple Configurator 2.

I can install the config profile manually with no issues other than it saying it's not signed. 

So I'm not sure if the issue is ProfileCreator building a bad config profile, or JAMF not being able to push it. I may try and get it signed and see if it changes anything.

 

Edit:

(Update)

I went through the process of importing the config profile I made with ProfileCreator into Apple Configurator 2 (where I'm signed into my org) - and I was able to sign the profile pretty easily. 

Uploaded the signed one to JAMF, boom was finally able to push it.

So it seems like the error people are getting in this thread may be from the profile not being signed.

 

It still shows unverified which I don't really like, so I'm going to find out how to fix that, but I'm happy I'm able to push it now without error.