"The file received was not valid" error while importing a new VPP token

Valued Contributor

I am attempting to import a new VPP token that I have downloaded from Apple business manager. Every time I try to do this, I get an error saying "The file received was not valid". I have tired using a different web browser. I have rebooted Jamf Pro, and I rebooted the entire Ubuntu server VM. The Jamf Pro server log does show an error at the time I attempted to import the token. I have an open case with Jamf for this, but if anyone knows how to solve this, that would be wonderful 😊


Valued Contributor

Jamf support asked me to try importing using a private browser window. That did it for me.

View solution in original post



Maybe it does not like the two dots in the filename. Try renaming to remove just one dot.

Valued Contributor

@chris.hansen Good idea, but that did not solve the issue. Thanks for your help! None of my other Jamf Pro servers need a VPP renewal, so I haven't tried this on another server.


I'm also getting this with my ADE token upload today. Renaming the file did not resolve it, but after I downloaded the Public Key from ASM and reuploaded to jamf, I was able to upload the ADE token successfully.

Valued Contributor

Jamf support asked me to try importing using a private browser window. That did it for me.

New Contributor II

I encountered this error today. Downloading our JSS DEP Public key, Uploading it to Apple School Manager, Downloading a new DEP Token from Apple School Manager, Uploading it our JSS DEP resolved it.

New Contributor II

Thanks - this worked for me today as well.

Worked for me too, cheers.

New Contributor II

This fixed it for ours as well, thank you.

This was the solution we are really looking for. Thanks.

That private browser didn't work much for me.

New Contributor II

Someone should really change the "solution" on this post as this downloading the public key process is what really works.

(Hello future me who finds this in November of 2023!)

New Contributor III

Life saver, thank you
This worked for me

New Contributor III

Yep. This needs to be marked as the solution...not using a private browsing window...

  1. Jamf
    1. In your Jamf Pro server, go to Settings > Global > Automated Device Enrollment
    2. Click "Public Key"
  2. Apple
    1. Log in to ASM/ABM
    2. Click your account in the lower left, then Preferences
    3. Select MDM server being updated
    4. Edit the MDM server
    5. Upload New (under MDM Server Settings/Upload Public Key)
    6. Upload the public key you just downloaded from Jamf
    7. Download the token for that MDM server
  3. Jamf
    1. In Settings > Global > Automated Device Enrollment, click on the MDM serving being updated
    2. Click "Upload Server Token File" and select the token just downloaded from Apple

That should do it.

New Contributor II

Downloading our JSS ADE Public key from Jamf, uploading it to ASM and then re-downloading the server token is what was needed for us. A private browser wasn't necessary in our case.

New Contributor

Worked for me as well. Thank you!

Contributor II

Had this happen to me again today. Don't download a new public key unless you have to - it will invalidate the old one and you'll have to upload it to Apple School/Business before getting the new Token from there. 

Jamf really could have updated the error message by now.