Self Service 0.27.0 issue

Contributor III

Hey everyone,

After updating our Jamf Pro instance to 10.27, self-service started to return the error "item failed" whenever I run any policy from it, so for example if I install Chrome from self-service, it gets downloaded and installed successfully but it still shows "item failed" after that !!!

Anybody is encountering a similar issue?


Valued Contributor II

Just ran a policy from SS and saw the same thing. Logs on the computer record report complete as well, but SS shows Error/Failed.


+1 happens here too since the update to 10.27

Valued Contributor II

Oddly enough, if I run the same policy again, it doesn't fail.....

UPDATE: in my dev instance it doesn't fail anymore, but in Production it does....

Contributor III

I'm only seeing this on M1 Mac's, for both ARM/Universal apps, and X86. They install and run just fine, but Self Service shows the error notification. The X86 policies install just fine on X86 Mac's, and no error messages.

Contributor III

same here, the issue shows up only on M1 Macs.

Valued Contributor II

interesting. On my M1 it fails the first time but works fine if i try and run again. But on an Intel its failing everytime.

New Contributor II

I am seeing this on Intel, as well. Contacted Jamf Support, but they are indicating they are unable to replicate issue. I am going to share logs...

Contributor II

I ran into this on a 2020 Intel MacBook Air for one of my clients. The policy initiated from SS seemed to fully execute just fine, but SS put up an error notification. Not sure I've seen it with any of my other clients. And not sure I've seen it on any of that client's other endpoints.

Contributor III

To add my data point, I found a repeatable way to cause the "This item is no longer available" error in Self Service.

I tested against our Jamf Cloud DEV instance that was recently upgraded to Jamf Pro 10.27. I did several tests enrolling a test Mac running macOS 10.15.7 (fully patched) using QuickAdd packages. What I found was that when I enroll using a QuickAdd package that was created with the "Method for Setting Password:" drop-down set to Random Password, I will consistently get the error with all of my Self Service policies. If I enroll using a QuickAdd package that has this set to Specify Password then all of my Self Service policies work fine. Additionally, the password I specified was fairly simple all lower case letters and numbers and only 12 characters in length.

The curious thing that I found is that in the case of using the QuickAdd with Random Password it appears to enroll the Mac and successfully run an initial inventory, but the Mac becomes Unmanaged! Since policies cannot be installed on Unmanaged Macs you will get this error in Self Service. I tested this theory on a Mac that was successfully enrolled, and stayed Managed, which I then manually unmanaged it in the JSS Web Interface and found that you get the same results in seeing the "This item is no longer available" error in Self Service.

Addtionally, I tested QuickAdds with Random Password vs Specify Password against our Jamf Cloud PROD instance (running Jamf Pro 10.26) and found that this error does not occur for either type of QuickAdd.

I also tested older QuickAdd packages I still had laying around for both our DEV and PROD instances that were generated using Recon 10.19 and using a Random Password. In our DEV environment running Jamf Pro 10.27, that QuickAdd caused the same error and also showed the Mac as Unmanaged. However, this time I noticed one additional quirk in that the Mac enrolled and ran an initial inventory but strangely reports that the Jamf binary version is still 10.19 while on the Mac itself the binary was actually upgraded to 10.27. The same test with the 10.19 version of a QuickAdd against our PROD environment running 10.26 shows that everything enrolls correctly as managed, the binary successfully upgrades to 10.26 (and shows this version in inventory) and Self Service policies run without error.

So in my mind there appears to be two bugs here:
1. Enrolling using a QuickAdd with Random Password causes the Mac to become Unmanaged only with Jamf Pro 10.27, and may be a bug specific to the Jamf binary itself.
2. Self Service incorrectly displays policies for Unmanaged Macs and should probably be smart enough to display an error that this Mac is Unmanaged rather than blindly showing you policies that you can't possibly run in an Unmanaged state.

New Contributor

Any updates on this. Brand new M1 Macbook Air is having issue installing Mac Apps Store App. Packaged apps are fine. iOS apps are fine. Only Mac Apps Store apps are consistently failing in Self Service. It was actually OK in the morning. Nothing was changed on the server. It just suddenly won't install anything.

New Contributor II

Wondering there is an update as I am running into the same issue.  Trying to install mac store app view self service on an M1 macbook Pro. Just get an installation failed error

Contributor III

The past few comments seem to be dealing with different issues, but I was wondering if any of the earlier posters are having the same issue or found a resolution? Just had a tech report that Self Service reports "Item Failed" for a Policy even though in Jamf Policy logs it shows it completed. I'm collecting logs from the computer, but I suspect (as others have mentioned) that the logs may just show that it succeeded. It IS an M1 computer, but I don't think it's reporting every Self Service Policy as a failure (only this one). We're running the latest version of Jamf (10.33).