Self Service 10.3.1 seems to be crashing a lot.

Valued Contributor II

Since I upgraded our Jamf Pro servers to 10.3.1, I see Self Service crash often. It's fine when when I relaunch it, but it's really annoying. We just brought on a new client for whom, we setup a dedicated Jamf Pro server, and to watch Self Service crash in the middle of a demo is a little embarrassing. It makes us look bad. Is anyone else seeing this?


Valued Contributor

I’m seeing this in 10.3.0.

Valued Contributor II

Right. 10.3 is doing it too. Let me guess. It’s a “known issue” that will be solved by version 10.x.

New Contributor III

I'm on 10.3.1 and just came across someone having this issue. Haven't figured out a solution yet. Tried re-installing self-service, and still crashing.

Any suggestions on what to try would be great.

New Contributor

I am on 10.3 and did not find this issue on my my self service, i am still observing it.

Release Candidate Programs Tester

I see this all the time on multiple instances, since 10.0. At first I wondered if it was a symptom of a clustered setup, but we have since set up a separate non-clustered single server setup and it still does it.

I think it may also be linked to Self Service “timing out” all the time, ie. not refreshing, even with cmd +R. This seems more prevalent on some servers than others, but no idea why. At the moment we have to tell users to close and reopen the app whenever they want to use it (if it hasn’t already crashed if it’s own accord), which is obviously a poor experience.

At one time I had a support ticket in for this, but their advice was to change the policy timeout setting, which didn’t solve the problem but I didn’t have time to follow it up. I’ll try and reopen the ticket next week.

New Contributor III

I am a jamfcloud customer on server 10.3.1 and am seeing crashing and not connecting on iOS self service client 10.3. This is not consistent across devices (I do not see a clear pattern yet). I am also seeing this on newly enrolled (pre-staged) devices unless I re-enroll. This is a real pain.

Any fixes out there I can do from my end?