Silent Installations - 10.11.x

New Contributor II

Hey everyone.

Bare with me as I try explain this, brain's a bit frazzled today.

So, we are trying to deploy Sophos... in every release until now we have had no issues and everything has sailed along smoothly thanks to some excellent community guides.

In anticipation for 10.11, Sophos released a new version of their AV for 10.11 and higher (9.4). The catch is that this can not roll out as an update from the Sophos Management Console. A new installer must be packaged and deployed.

No problem right? Wrong.

For the life of me I can not get the installer to run silently via terminal. I have heard back from our support vendor and got this oh so helpful reply...

"El Capitan is still very new but apparently you cannot run silent installs on OS X 10.11 and I haven’t come across a way to circumvent this. Sophos KB article that lists current install options via terminal is "

Is anyone able to shed some light on validity of this statement? I can't believe that Apple would remove the functionality to run silent installations?



Valued Contributor

You are probably going to have to repackage their as a .pkg using a snapshot in Composer.

You can absolutely install silently on El Capitan, just maybe not with however they setup their

Contributor II

New Contributor II

@lkrasno Is that deploying 9.4 to 10.11? I've followed that guide, we've used it for older versions.

Release Candidate Programs Tester

@Josh.A I've not got 9.4.. yet.. nor had much time to play with 10.11 :(

Can you try & report back?

If you haven't already, I'm happy for you to send the link @lkrasno posted to your Sophos support person. They need to get the message.

New Contributor

Agree we are in the same boat and had great luck with Composer.

Valued Contributor II

I'd be wary of using Composer snapshots with Sophos installer.

Last one I deployed was 9.2 using @rtrouton method, and I won't be looking at el cap and 9.4 for a few months, but there's also this link from sophos with details to get the Mac in the right group as part of the install

How to automatically assign a Mac endpoint to a defined group in Sophos Enterprise Console

Valued Contributor II

It seems to us that Sophos 9.2.8 works fine with El Cap. This is the current recommended, with 9.4.0 being on the preview release channel. My Mac is on the preview channel, and it updated from 9.2.7 to 9.4.0 automatically from our Sophos server.

Valued Contributor II

We've reached out to Sophos tech support to confirm this article will allow silent installs:

Article ID: 119744
Title: How to create a pre-configured installer containing updating and On-Access scanning options


I logged into our Sophos support page and it shows 9.2 supporting Mac OS X 10.6, 10.7, 10.8, 10.9, 10.10, 10.11


New Contributor II

Morning everyone,

So it seems like there's lots of mixed responses here. I'll go through and try each one out and see how I get on.

@bentoms I did try using your method first (as we've used it in the past) but I may have done something wrong so I'll try again.

@dan.snelson Thanks for that link. Looks very promising also.

I'll report back ;)


Release Candidate Programs Tester

@Josh.A Thanks.. i'd be very much interested in your findings.

Valued Contributor II

Following Sophos article 119744, copying the entire contents of the .DMG to a temporary directory and then executing the following command in a post-install script seems to be working for us.

/path/to/tmp/folder/SophosMac9.4.0/Sophos --install

New Contributor III

I banged my head against a wall with Sophos. I finally went the lazy route and setup an HTTP file server on my jds mac to deploy the installer. For some reason, I also get an error the first time I run it, so I run it twice. Sloppy but I just needed a solution. Albeit, I'm not using Enterprise. This is what worked for my for 10.11

A tail from a successful installation:

creating: savosx_he_r/Sophos Installer Components/savi.bundle/Contents/Install/Root/savi/
inflating: savosx_he_r/Sophos Installer Components/savi.bundle/Contents/Install/Root/savi/savi 
+ /usr/bin/logger 'Installing Sophos'
+ echo 'Installing Sophos'
Installing Sophos
++ '/tmp/savosx_he_r/Sophos Anti-Virus Home' --install
## Checks exit code:
+ '[' 139 == 0 ']'
## Not equal to zero so reruns.
+ '/tmp/savosx_he_r/Sophos Anti-Virus Home' --install
The installation was successful.
+ /usr/bin/logger 'Sophos Installation Succesfull'

New Contributor II

Just as an update for anyone following this.

We're still having no luck deploying Sophos silently to 10.11 machines.

I'll post again once we figure it out.


We're able to do a silent install on El Capitan by copying the .dmg and running the script below


Switch directories to Sophos Folder

cd /Library/temp/Sophos/Sophos

Install Sophos

sudo "./InstallationDeployer" --install

exit 0"