Teamviewer intergration - self service notifications not working

New Contributor III

Hi All,

I have set up to integrate our Teamviewer and Jamf but when i start a session and click on "Send Self Service Notification", nothing comes up on the mac. We have enabled self service notifications so i am not sure what is wrong but if i manually open up self service then i see the link for teamviewer.


Any ideas?




Honored Contributor II

In addition to enabling notifications for Self Service, verify two other things:

  1. In Jamf Pro under Settings > Global Management > Push Certificates, you need to have a Push Proxy certificate in addition to your MDM Push Notification Certificate.


  2. Under Settings > Computer Management > Security, you need to enable the Notifications profile for Jamf management framework and Self Service.


New Contributor III

I have all those set and it works when i use the user interaction tab in policies. So not sure what is wrong here, only not working for teamviewer.

Same behavior.
Did you find a solution ?

Thank you

New Contributor III

Unfortunately no, i tried on few of my mac devices and they all are behaving the same.

I just deleted and re-created the Push Proxy Settings certificate but still the same problem. Self We have tried on 10.15, 11.x and 12 beta 6 without success.

I tried to uncheck "Jamf management framework and Self Service" in Settings -> Computer Management Framework -> Security then wait 30mn and check the option again but without success.

However, I can see the self service in the list of applications in the notifications center and everything seems correct.

I also tried adding "com.jamfsoftware.selfservice.mac" and "com.jamfsoftware.Management-Action" in the Notifications payload of a configuration profile but still not ...

New Contributor III

Did you get anywhere with this? I am still not getting the notification.

Contributor II

Still not, I opened a support ticket.
I'll let you know if we can solve the problem


I've just configured this integration and I'm having the same issue.
I also connected my MacBook to my phone as hotspot to rule out our network. I think the problem is either with Jamf itself or Sophos Endpoint.

New Contributor III

what makes you think it is sophos endpoint? We are also using it and it would be interesting to know that it is Sophos as it was causing us some other issues recently. I will test by removing Sophos.

Valued Contributor II

I don't use sophos and we still are not getting the notifications on Teamviewer.

Gabe Shackney
Princeton Public Schools