Teamviewer intergration - self service notifications not working

asidhu
New Contributor III

Hi All,

I have set up to integrate our Teamviewer and Jamf but when i start a session and click on "Send Self Service Notification", nothing comes up on the mac. We have enabled self service notifications so i am not sure what is wrong but if i manually open up self service then i see the link for teamviewer.

 

Any ideas?

Regards,

Ameetraj

20 REPLIES 20

talkingmoose
Honored Contributor II

In addition to enabling notifications for Self Service, verify two other things:

  1. In Jamf Pro under Settings > Global Management > Push Certificates, you need to have a Push Proxy certificate in addition to your MDM Push Notification Certificate.

    push-proxy.png

  2. Under Settings > Computer Management > Security, you need to enable the Notifications profile for Jamf management framework and Self Service.

    notifications-profile.png

asidhu
New Contributor III

I have all those set and it works when i use the user interaction tab in policies. So not sure what is wrong here, only not working for teamviewer.

Same behavior.
Did you find a solution ?

Thank you

asidhu
New Contributor III

Unfortunately no, i tried on few of my mac devices and they all are behaving the same.

I just deleted and re-created the Push Proxy Settings certificate but still the same problem. Self We have tried on 10.15, 11.x and 12 beta 6 without success.

I tried to uncheck "Jamf management framework and Self Service" in Settings -> Computer Management Framework -> Security then wait 30mn and check the option again but without success.

However, I can see the self service in the list of applications in the notifications center and everything seems correct.

I also tried adding "com.jamfsoftware.selfservice.mac" and "com.jamfsoftware.Management-Action" in the Notifications payload of a configuration profile but still not ...

asidhu
New Contributor III

Did you get anywhere with this? I am still not getting the notification.

glpi-ios
Contributor II

Still not, I opened a support ticket.
I'll let you know if we can solve the problem

luispalumbo
Contributor

I've just configured this integration and I'm having the same issue.
I also connected my MacBook to my phone as hotspot to rule out our network. I think the problem is either with Jamf itself or Sophos Endpoint.

asidhu
New Contributor III

what makes you think it is sophos endpoint? We are also using it and it would be interesting to know that it is Sophos as it was causing us some other issues recently. I will test by removing Sophos.

Hi @asidhu,

That's the only thing that could be blocking my connections. But apparently there's nothing to do with it.

GabeShack
Valued Contributor II

I don't use sophos and we still are not getting the notifications on Teamviewer.

Gabe Shackney
Princeton Public Schools

samuellarsson
New Contributor III

I'm also seeing the same issue here. No Sophos or other 3rd party security software here either.

glpi-ios
Contributor II

Since Jamf 10.33, we still have the problem of notifications that are not displayed but in addition, when we try to trigger a remote session via the JSS, we click on "Start session" in the workstation inventory and we have the message: "End user is offline" while the computers are reachable (Check-in and inventory OK).

Screenshot 2021-10-28 at 11.49.04.jpg

Hi @glpi-ios,

The End user is online will show after the end user starts the TeamViewer session by using the provided link.

At the moment, the user is not being notified by Self Service but if you tell them to access that particular link it should work. Then you as the remote person can click on the link available as the admin user and connect to it.

glpi-ios
Contributor II

Hi @luispalumbo 

Indeed you are right, it works well, you just have to warn the user to go to their Self Service / Bookmarks.

So the only remaining problem is about notifications.

Thank you for your help

ZachWC
New Contributor

Currently running into this issue.  Has anyone found a work around?

lukasz_slodziak
New Contributor III

Hey! I just wanted to join the conversation to thank you for all the reports of inconsistent, or in some cases, completely ineffective notification delivery. We will be investigating the issue, but I'd like to encourage you to continue reporting and providing additional feedback that can provide more context.

Some reports said that pressing the Resend Self Service notification button forces the notification to appear on the end user machine. This results in two notifications, which is still incorrect, but at least the notification reaches the user. Has that also been your experience?

Thank you again for your your feedback!

Resending doesn't do the trick for me either. 

glpi-ios
Contributor II

@lukasz_slodziak pressing the Resend Self Service notification button doesn't work for me 😞

Cyberghost
New Contributor III

Hi all, 

I saw this issue 2 month ago that some notifications via Patch Management or like here for TV is not displayed to the enduser. 
My ticket is closed based on the PI-010131 that was opened for this. Perhaps you can verify the problem and use the PI as a reference.