there was an error creating the new object in the JSS

Not applicable

Attempting to add printers via Casper Admin with the above message.
Also cannot create new categories via Casper Admin app.
Can only create new categories via JSS under the Management Framework.

Thoughts ?

Andrew Jezard
(MacBook Program Administrator)

Sacred Heart College
Retreat Road
Newtown 3220

Tel: (03) 5222 0520
Fax: (03) 5221 3634

![external image link](attachments/aab8588ac2f845bc99976e287ece6d0a)


Not applicable

When I try to add a printer in Casper Admin I get the following error:

there was an error creating the new object in the JSS

Anyone else having this and can guide me in the right direction to fix this issue ??


Jason Kong

New Contributor II

sometimes we have issues if the printer WAS in the JSS and you've deleted
In those cases, we have to empty the trash and hit SAVE (or maybe reatart
admin) before it'll take the new printer.

*ben** janowski*
Senior Macintosh Support Technician
*Kohl's Mac Support Team *| 262.703.1396

Not applicable

Tried that and still giving me the same error. I even tried to reinstall JSS and it didn't work either.

Jason Kong

Apple Support Specialist
Queens College DH-154
Office of Converging Technologies

Jason.Kong at

Release Candidate Programs Tester

Try opening casper admin on another machine...
Sent from my BlackBerry® smartphone on O2

Not applicable

Already tried opening Casper Admin in 5 different Macs and all give me the same error.

Jason Kong

Honored Contributor

You have triple checked there already is not an object in casper admin
that has the same name? Delete the old one and so forth?


New Contributor

Hi Guys,

I am having the same issue. What is strange is that I after I receive the error I can see the Object in Casper Admin, but the printer is not listed as a deployable printer in Casper Remote. This only happened yesterday when trying to add and Epson 4900 Printer. I have verified setting and emptied my deleted items in Casper Admin.

New Contributor

Having the same issue with a Phaser printer. I get an error when trying to add the printer is I use the Xerox driver PPD, then the printer arrears as an asset but I cannot deploy it. This is weird

New Contributor

I found a fix, let me know if you you still need help on this. Worked for me. Had 3 printers I could not add Epson Stylus Pro's and a Phaser.

Contributor II

@mvanvliet - What was your solution?

Valued Contributor II

I'm having the same issues after some Database issues. My installation packages are there and seem to work, but my scripts aren't functioning. Deleting and re-adding them brings up the same message that you were getting with your scripts.

New Contributor III

I am also experiencing this error when attempting to add a Xerox Phaser 7760. I've made sure to empty the trash, as suggested, to no avail. @mvanvliet, what was your solution?


We have seen this error before and it typically comes down to increasing your max packet size in your mysql settings. In order to do this, we would want to go into the JSSDatabaseutil.jar /Library/JSS/bin on a Mac OSX Server
C:/Program Files/JSS/bin on a Windows Server
/usr/local/jss/bin/ JAMFSoftwareServer.log on Linux Server
Under the Utilities menu, select Change mysql setttings. From there we can increase our max packet size. We recommend just increasing this temporarily. Some printers that come in with driver data can be pretty big and overtake that max packet size. Please give this a try and post your results or contact your Account manager for troubleshooting.



I had this exact same issue adding a Xerox Phaser 7760dn. Joel.Peasley was correct that this issue comes down to packet size (the Xerox PPDs are large), however, the "Change mysql settings" option is not available in the JSSDatabaseutil.jar when the JSS is installed per JAMFs currect instructions on Mac OS X 10.8.

Here's how I fixed it on Mac OS X 10.8.2 Server running the MySQL installation straight from Oracle:

Back everything up and prepare to make the JSS unusable for a few minutes

Stop MySQL using either the Preference Pane (if installed) or running

sudo /usr/local/mysql/support-files/mysql.server stop

Copy the default "huge" MySQL configuration file to /etc by running

sudo cp /usr/local/mysql/support-files/my-huge.cnf /etc/my.cnf

Edit /etc/my.cnf to increase the max_allowed_packet. You'll find the variable listed not-too-far-down under the [mysqld] heading. Change the value from the default of '1M' to '500M', ie: "max_allowed_packet=500M"
Save the file and exit.

Restart MySQL using the Preference Pane of running ```
sudo /usr/local/mysql/support-files/mysql.server start

You can confirm the change by running a query from MySQL interactive mode, ie:

sudo /usr/local/mysql/bin/mysql


show variables like 'max_allowed_packet%';

If you used the above value of 500M, MySQL should return:

mysql> show variables like 'max_allowed_packet%';
| Variable_name | Value |
| max_allowed_packet | 524288000 |
1 row in set (0.00 sec)

Restart Casper Admin and you should now be able to add the printers (or whatever problematic items).

New Contributor

I'm having the same issue on a Windows box.

I have verified the files are in the right location, but still get the error. I have even logged into the box as an Admin, but no joy.

Win 2008 R2 - JSS 8.7

Thanks in anticipation.

New Contributor

The modification as described to the my.cnf file worked flawlessly!! Thanks!

Now I can add our new XEROX 7835 MFCs to the JSS!!!!

New Contributor II

Thank you, I had the same problem adding Epson 4900 and 9900 Stylus Pros and Joel.Peasley's solution worked.

New Contributor

I also had this issue while trying to deploy a Xerox 7835, and the solution above worked perfectly.

@Joel.peasley and @bmwarren - Thanks for the help.


I got the same error message just adding a 39MB package file to Casper Admin. I tried adjusting the MYSQL settings (as suggested above) and that didn't have any effect. I then tried to delete a different package in Casper Admin and it said I didn't have privileges to do so. The account used to sign into Caper Admin was an LDAP Full Administrator (everything was checked) account. I then tried a standard user to sign into Casper Admin and was able to add/make changes. So I narrowed it down to my account being the issue. I then signed into the JSS with a different Admin account (standard user) and deleted my LDAP Admin account, re-added it with Full Administrative privileges, tried Casper Admin again and was able to add/delete packages.

The only recent changes to our JSS system was we started using Sites and we added another LDAP server. So I don't know if any of that had to do with the issue.


A Windows secondary domain controller update caused this issue for us.

Valued Contributor

I got this error today. Did the database check in Casper and then searched here.

Our JSS is running on OS X 10.7.5 Server with MySQL Community 5.5.17

I tried the steps from bmwarren and confirmed that max_allowed_packet was now larger but still got the error when I uploaded a new version of Java to the JSS using Casper Admin 9.32. Very frustratedly I rebooted the server and it's now working correctly. So not sure if it was the change in packet size or the reboot.



New Contributor II

Good stuff, @bmwarren . That worked perfectly.

New Contributor

I had a similar error, and it turned out to be either the name of the printer was too long, or the location field had too many characters in it, once I deleted the characters it added fine.