Unmanaged iPad still says it is supervised

New Contributor III

Hello all,

We unmanage our devices we give to students after graduation as they get to keep them once they finish. I noticed that after I unmanaged the device and the command removed self service and the profiles that the devices still say they are supervised in the settings app.

Did I miss a step or do it incorrectly?


New Contributor II

I also have this issue. After you click Unmanage the button changes to say Mark as UnManaged but when you click it it gives a Bad Request error.

New Contributor

Related comment - we are going to do this gifting as well - when you unmanage do the apps you own return to your inventory as available and remove themselves from the iPads or do the end users/new iPad owners need to manually delete the apps? I haven't found details on that.

Release Candidate Programs Tester

Supervised devices will remain Supervised until they are erased. Since Supervision is simply a mechanism to tell institutionally owned devices to honor certain profile payloads only when Supervised, it should not affect an unmanaged device.

That being said, since your students are likely signed in using a Managed Apple ID when using a school owned device, they should probably be instructed to erase the device and sign in using a personal Apple ID once the device has been released and becomes their personal device.

New Contributor

From Jamf Pro I selected unmanage the managed apps (that were purchased with vpp), the self-service app, and the MDM Profiles were deleted. After I wiped the device and restored from an iTunes backup the device still showed the message at the top of Settings that it was supervised by our company. Any way around this without making the user start over?

New Contributor II

This is simple... as long as the serial number of the device is still checked in a prestage, the erased device will be checking in with supervision again and again. You'll need to either unmanage the device in Apple School Manager (better solution) or at least uncheck the device in your according prestage