VPP invitation not updating

bhouseward
New Contributor II

I cannot seem to accept an invitation to VPP on an iPad. I've tried with both the prompt and via email. The first time I signed into the App Store at the prompt, I agreed to terms and conditions for organization and I got the confirmation that "This organization can now assign apps and books to you." However, even after a day, my invitation remains unaccepted in the JSS.

If I try to resend or click a link in the email again, I can sign in but I keep getting the message "Unable to Allow Assignment of Content. Check that your AppleID and password are correct and try again."

To be sure that I was typing my password in correctly, I signed out of the App Store and clicked the invitation link again. I had to enter both my AppleID and password, and when I submitted I saw my AppleID appear in the bottom left of the App Store in the background, so I know I was signed in correctly, but I still got the error and my invitation shows as unaccepted in JSS.

This happens with at least 2 AppleIDs, and I've tried creating a few different invitations but they still don't show up as accepted in JSS. Am I missing a step along the way somehow?

2 REPLIES 2

were_wulff
Valued Contributor II

@bhouseward

Is this happening on one single device, or is it happening on multiple devices?
If it's just happening on one device, we've sometimes found restoring that device and trying again takes care of the problem, but if it's happening on multiple devices there may be something else going on.

There are a few different things that can cause this, but we'd rather be able to take a look at some log files first so it's not just a stab in the dark; it would be best ,if you haven't already, to open up a case with your Technical Account Manager so they can look at it a bit more closely with you.

Thanks!

Amanda Wulff
JAMF Software Support

bhouseward
New Contributor II

Thanks Amanda,

I've had this on 2 devices with 2 AppleIDs. Unfortunately I just finished collecting and re-distributing all the iPads to unsupervise them from Apple Configurator so I could supervise them with Casper Suite instead, so I'm not excited about collecting and restoring all those devices again.

I contacted my Account manager who created a support ticket, so I'll see what they can find. Thanks.