VPP issue: "Pending - application is not available to install"

mvillasana
New Contributor

I'm seeing this issue with several of our apps coming from VPP.690eefde92db42c789122a186fda8956

The user is enrolled to receive content and there are plenty of licenses available.

Any ideas??

41 REPLIES 41

mpermann
Valued Contributor II

@mvillasana is this for Mac OS or iOS? What version of the OS/iOS are the apps trying to be deployed to?

mvillasana
New Contributor

Sorry! This is iOS. This particular iPad is on version 8.4.

freddie_cox
Contributor III

Just came here to say I'm seeing the same thing today as our staff has returned and started pushing out apps. Also on 8.4. Been trying to find a rhyme or reason as to why.

The app is assigned to the user in their Purchased tab, they just aren't receiving the push install.

Reno
New Contributor III

Check your VPP program invite logs for the users in question. I encountered this issue and found that even though the JSS had reported the appropriate number of license were in use and the users were enrolled, the accounts displaying this error had a second invitation sent that needed accepting. After that I flushed all errors from the machines' entries and pushed an inventory to trigger redeployment, which worked like a charm.

freddie_cox
Contributor III

Thanks Brad - This location has 100% acceptance on their VPP Invites and the app appears in the users purchased tab after it is assigned, they just aren't receiving or responding to the push correctly.

We're also running a caching server on 10.10.4 that appears to be working as expected as I can see requests going out when they're requested.

Simmo
Contributor II
Contributor II

Is this with managed licenses or codes?
Are the devices supervised?

Emmert
Valued Contributor

And they have the license assigned in vpp2, as well as it being in the main app catalog?

It could also be another iTunes outage.

Simmo
Contributor II
Contributor II

@freddie.cox I actually seem to be seeing the same behaviour, apps are not silently installing as they should be on supervised devices, but it is appearing under purchased in their app store.

freddie_cox
Contributor III

@Simmo @Emmert supervised & Managed Distribution. I advised the location to wait it out and see where they were at this morning. We could be seeing some throttling. I'll lcheck in with them a bit later on and see where we are.

Thanks - seems like there are several of us in he same boat.

jcoombes
New Contributor

We are seeing the exact same behaviour. App shows up in the purchased history (so the VPP assignments/acceptances are ok), but when we go to install via the self help portal it won't install with the same message that the OP had.

Supervised devices, newly erased and enrolled via the DEP. The managed install of Casper Focus as the Self Help portal as well as free apps install without a problem. iOS 8.4 and JSS 9.73

Any update on this???

millersc
Valued Contributor

Question.. are you using the Self Service Web clip or the Self Service Mobile App? We've been seeing problems with using the Mobile App, the Web clip is slow, but seems consistent in working.

natesimons
New Contributor III

Same issue happening for me...but only paid apps. Hope we can discover a solution as I have some not patient teachers.

Moserschule
New Contributor

I got the same problem, paid apps couldn´t be installed on iPads that were enrolled via DEP. I opened a case and got the following solution that worked for me. Maybe it can help you too.

*From the previous communications, it appears as though we are attempting to distribute a paid app to iOS devices using VPP.

Although these devices were enrolled through DEP, VPP will not be automatically installed on the device. However, it is still possible to use VPP -- we will just need to follow a few more steps.

How were we planning to use VPP -- through a spreadsheet uploaded in the JSS or through VPP invitations/VPP assignments?

If we plan to use the latter, than each device will need to accept a VPP invitation sent by the JSS before we can assign content (apps) to them.

Please see pages 9 - 13 of our Technical Guide on DEP/VPP for detailed instructions:
http://www.jamfsoftware.com/resources/simplifying-device-enrollment-and-content-distribution-using-dep-vpp-and-the-casper-suite-v96/
*

JAMFatJESD
New Contributor

We are having the same issue with paid apps on ios 8.4.1 and JSS 9.73. In our case the blame is being put on ports in our firewall but, our port scan just showed that the required ports and ip scope for APNs are all fine.

I do hope that a solution is found soon. More troubleshooting to follow.

BTW I am testing on the newly released ios 9 to see if that fixed any of our issues.

joergradler
New Contributor

Having the same issue, anyone have an update on this? I updated my VPP purchases and it shows we bave plenty of licenses.

CGundersen
Contributor III

I've received reports of this (e.g. Keynote and iMovie). We are at 9.73 (production), Self Service App with majority iOS 8.4.x clients. It was suggested that iOS 9 might provide relief, but (in limited testing) I was able to reproduce with iOS 9.0.1 (*9.73 JSS). Curious if any others having the issue are blocking the App Store? I changed up my scoping (removing App Store restriction) and Keynote and iMovie hit my test iPad. Still need to test a bit more ... iOS and VPP not my forte.

Dave_K
New Contributor

Hi,

I'm experiencing the same problem here. Trying to install "Texpad : LaTeX editor " on 2 of our Teacher-Ipads.
One Ipad is running 8.4.1 the other was updated just now to 9.0.2. Unfortunately the problem still occurs.

Have you been able to fix your issue?
b4b2872a132048a28b3a12b195f2152f
Any Advice?

Emmert
Valued Contributor

Usually these kinds of errors are because there's something stuck on the user end ... try logging out and back into the iTunes ID, and see if they can buy a free app from the App Store or iBooks.

Next, check their VPP email and make sure they accepted it and all prompts. Typically there's some license agreement or something that they still need to click through.

jcarr
Contributor III

I'm seeing this now with device based app assignment in 9.81. I'm trying to avoid the need to have users sign into the app store in order to get Self Service Mobile installed. I've purchased more than enough licenses, and (I believe) set it up correctly. Self Service mobile should be installed on iOS 9 devices via VPP, even with no user signed into the store.de9d08d04831448b8ca97c8941c880d9
457823f589aa4d4d93fee59ad1786dd4

inventaire
New Contributor

Hello,

I have the same problem and actually the only trick I've found is to remove the event pending by push "cancel" and update inventory device for each application that poses problem. The problem being random. The devices are under iOS 9.0.2, the JSS server 9.81, I also used a VPP accounting and device assignments as jcarr
If someone finds a real solution I thank in advance

tcaldwell
New Contributor

Has anyone found a resolution to this? I am experiencing the same issue. So far two different users both running iOS 9.0.2. Casper hosted JSS 9.73.1436909640.c. Only happening on paid VPP apps. Both users are associated with VPP and I have been able to push out paid VPP apps to them in the past. Trying to push different apps to each user with the same results.

St0rMl0rD
Contributor III

We're seeing this even with device-based VPP assignments in 9.81. The error message is there, but the app still installs, very strange. There's enough licenses, of course.

murph
New Contributor III

I am seeing this a lot on 9.81 on iOS 9.0.2 too for device based assignments.

Pending - Application is not available to install

promalley
New Contributor III

Chiming in to say I am experiencing the same error "Pending - Application is not available to install"

Running:
IOS 9.0.2
JSS 9.81
Free App with 1000 managed app licenses

Have not seen a resolution yet and canceling the "push" and updating inventory has not resolved the error

jhohlbauch
New Contributor

I'm experiencing the same issue with a few devices (iPad's). Same thing I have enough apps and we are only seeing it on the iWork's/iLife apps right now. Hoping to find an answer soon.

Maxim
New Contributor II

I was experiencing the same issue of "Pending - Application is not available to install" with v9.81 and device based assignments.

Fixed in my environment by:
Global Management >VPP Accounts > select account > content tab > "update purchase content" button

search for VPP app that is failing and select add.

rbent
New Contributor

The above solution should help. Next to each app is also a refresh to do the same thing.

My problem was when the iPad went into a lock mode and the screen went dark after restarting iPad. The teacher using it said she turned on Accessibility mode and adjusted a few settings in there. So I had to wipe the device and reinstall everything. The apps were still assigned to the created apple id so I thought it wouldn't be an issue, but it never cleared the apps from the user account locking the apps in use. So I tried the refresh next to an app and "update purchase content" below, but you have to search for the app in question and just add it again. I also went into Self Service and clicked on app to see if it would install and it did, so I can't exactly tell you which sequence worked for me. Not all the apps installed automatically either. I would clear any failed apps etc that may hold up new app requests. They are slowly coming down, but I just cancel apps hanging and may just repeat the steps. Good luck.

rbent
New Contributor

Update:
Do what Maxim suggests

Fixed in my environment by: Global Management >VPP Accounts > select account > content tab > "update purchase content" button search for VPP app that is failing and select add

And if you continue to see issues, try this.
Find the device in question with the hanging apps and check the Management tab and click the Update Inventory button to see if that changes the status of the app to pending... If so, give it time, if you see an app still saying "Pending - Application is not available to install" go to Global Management >VPP Accounts > select account > content tab > and just Refresh the individual app.
Then go back to the device in question and see the status change to Pending. Just give it time to sort itself out and you should see your app install within a few minutes.

stwrz
New Contributor II

Just wanted to chime in to say that the above solution did not work for me. I still the the "Application is not available to install" message.

joalah
New Contributor II

I am having this problem as well I am on iOS 9.1

lehmanp00
Contributor III

I too have seen this more than enough times on iPads. I have some troubleshooting steps that I go thru that usually clears the issue:

  1. Refresh the App for the VPP account (what Maxim suggested)
  2. Refresh the license count in the JSS for that app. (very similar to #1 but just hit the Refresh button next to the app)
  3. Login as the Apple ID (if you can) at https://appleid.apple.com/. (I think this clears a lockout of the Apple ID or something like that)
  4. Login to the iTunes store as that Apple ID. Accept any new EULAs that might pop-up
  5. This is a little tricky.... Make sure the user, device and app catalog entry are all set for the same site in JSS. I have found that if they are on different sites, the app will either not show in Self-Service or look like it wants to install but not.
  6. Swear this one has worked from time-to-time. Just reboot the ipad.

All of these have worked for me. In combinations or not.

Hope this helps!

EDIT: I forgot a big one. Restart Tomcat on the server...yep. We have had everything look OK in the JSS but actually there was no comms between the JSS and Apple's Magic Cloud. Restarting tomcat fixed it. Done that 2x now.

cddaconta
New Contributor

I have tried everything on here to no avail. Can an admin of these forums chime please chime in?

guzmanhm
New Contributor II

Can confirm that lehmanp00's that process works

anitasmith
New Contributor

I have tried all suggestions above, including restarting the topcoat - nothing works for me either.

Emmert
Valued Contributor

Have you tried clearing out all the pending commands so they can be reissued? There's a way to do this in bulk through MySQL if that fixes it for one iPad.

lehmanp00
Contributor III

@anitasmith

The whole VPP thing is very picky on many fronts. You have to have all your 'Ducks-in-a-row' for it to work correctly.

Since iOS 9 came out, the requirements changed a bit from iOS 7/8. (of course none of this was communicated out very well)

Basic workflow is this: (for VPP Managed Distribution)

ALL apps (Mac or iOS, free or paid) should have a VPP managed license.

An MDM needs to know about that license (in this case JSS)

The License needs to be assigned to an Apple ID (at this point, the Apple ID should see the app in the purchased tab of the App Store app and can install from there)

(* Remember, the Apple ID needed to accept a VPP invite for each VPP account it might get licenses from)

The App needs to then have an entry in the MDM App Catalog (So Mobile Devices>App in JSS)

The App entry then needs to be assigned either to a user/group/ldap group or device so it shows up in Self-Service.

There are a few differences you could have:

If you want to assign VPP licenses to iOS 9 devices than you can skip assigning to Apple IDs.

Under-13 Apple IDs will ALWAYS ask for the Apple ID password when installing apps unless they are installed thru Self-Service. (that part really upset my K-12 org. Long phone calls with our Apple rep on that)

Where things bog down:
The JSS isn't getting updated info from the Apple Cloud (VPP licenses info mostly)
Apple ID never accepted VPP invite
Apple ID is locked on Apple's end
Device not at iOS 9
Device cannot communicate with the JSS correctly

This, in my experience, is the most common:
The JSS isn't getting updated info from the Apple Cloud (VPP licenses info mostly)

*one other thing to try...
Login to your VPP accounts and download a new token for the JSS. Then upload that new token to the VPP account in JSS. That can refresh all the secret Apple protocols that the JSS uses to talk to the VPP accounts.

GabeShack
Valued Contributor III

Fix for me was to run this in sql on the JSS(should fix this in bulk):

update vpp_admin_accounts set licenses_since_modified_token = '';

Then be sure to restart tomcat.

Gabe Shackney
Princeton Public Schools

Gabe Shackney
Princeton Public Schools

kirk_magill
New Contributor

52349bee9548490cae856793cc949c65
Check your VPP token expiration date.
Go to Global Management >VPP Accounts > select account > content tab > Expiration Date: Date that the service token expires.

If this is expired it will not work. You have to download a new one from the Account Summary of your VPP account.

bgernhardt
New Contributor

I was able to fix this issue by adding the iPads to the exclusion list for the app in question. After forcing an 'Update Inventory' and making sure the iPads received the update command, I removed the iPads from the exclusion list. This allowed the app to install without errors.

I would like to take this opportunity to thank JAMF and their support. With their help I would STILL be trying to fix this issue.