Adobe CC (Apple Silicon) pkg still failing within JAMF


Adobe Enterprise now has the option to create a pkg for Apple Silicon devices. With this option, I assume the below workflow for creating a pkg for Apple Silicon devices is no longer needed? I do not see the InstallationCheck when I go into resources.

When I create a new pkg(Just Adobe CC) and run manually on a M1 device with Rosetta2 installed it installs correctly. I am also able to install necessary apps if needed.

However when I upload the same pkg and run via a policy on the same device with Rosetta 2 installed it fails and I get the following message.

Installation failed. The installer reported: installer: Package name is AdobeCreativeCloud_NamedM1_04162021
installer: Installing at base path /
installer: The install failed. (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance. An error occurred while running scripts from the package “AdobeCreativeCloud_NamedM1_04162021_Install.pkg”.)

Has anyone been able to get this to work?


New Contributor II

@jschank What applications are included in your package? You can only package Apple Silicon supported apps in the Apple Silicon package at the moment. It'll let you put in Acrobat but it's not a native app, so the install fails. I'm currently deploying just the Creative Cloud app with users able to self-install Acrobat until a better option is available.


@ cmarstaller1769 I am not packaging any additional apps with the Adobe CC app. I leave it up to the end user what they will install after they authenticate using a Federated account.

So I am basically trying to do what you are doing. After I create the pkg for M1 devices via the Adobe Admin Console I am just uploading the installer to Jamf.

New Contributor II

@jschank It should work then. The only thing I've seen is that the installer will fail if Safari is opened. I'm not sure why it does that on occasion. The Apple Silicon installer should do the job... are you getting any errors out of Jamf?


@cmarstaller1769 can it be the name of the pkg, AdobeCreativeCloud_NamedM1_04162021? Since it is running a script. The error I am getting is in the 1st post I provided.

New Contributor III

For Acrobat DC Pro in specific, I had it fail on both M1 and Intel macs because I had Safari app opened and or the Microsoft Outlook app. Make sure those both are closed before installing DC Pro in specific. (confirmed by Adobe support that safari and outlook need to be closed before install)

Also, not sure if there is a word count limit to naming pkgs, but maybe try shortening the pkg name, or by putting the date of the app created within the notes. I was testing out other apps and noticed when the pkg name was too long, it kept corrupting once uploaded to JAMF.

But other than that, I have no issues with deploying any of the Adobe 2021 Apps to M1s or Intels. No error messages from installing through self service. I did have to delete and upload (troubleshoot/test) the software(s) multiple times, which took a while...

Contributor III

i'm experiencing the same issue with the same error message from Jamf.
I made sure that Safari is closed and the name of the pkg is short "Adobe CC_M1" but still with no luck.

@G_Zirrak how did you deploy it on intel and M1 macs if I may ask?

Contributor III

@jschank I just tried to upload the pkg downloaded via Adobe admin console via Jamf Admin and it worked!!!


same issue
I do this a few times a year, last one i did was in Feb 2021 when intel was the only option.

Now i have issues with the new intel and AS installers. They always fail with jamf install.


Same issue here. Today I downloaded a new Self Service PKG (Apple Silicon) from the Adobe Admin Console. Uploaded the .pkg to Jamf and it fails with the same error as shown above on my test macBook Pro M1.

New Contributor

@Musicmaker I am having the same issues as well. I created/downloaded a Apple Silicon PKG for both the Adobe CC ( App Package) and with an individual app method that I've been reading that some people are getting results out of. I was wondering if you've been able to figure it out or anybody in this thread. Always appreciate the help this community provides, thanks.


@tusdafif Eventually it worked for me. It's a bit stupid that I didn't post my solution here earlier. There are 2 things:
1. I ended up by uploading the Adobe CC SelfService package through Jamf Admin to my Jamfcloud instance. For some reason after that it worked
2. Last week I was deploying Shared Device Licensed packages for our student Mac's. When I was checking a specific Mac I found out that Premiere wasn't there. So I checked the policy logs and....... same error: "Try running the tool again". But now the surprising fact: This wasn't a M1 Mac. On all of the student computers Premiere, Photoshop etc. failed to install with the same error. While searching for a solution I found this tip:
- Extract the zip from Adobe
- Go into the Build folder and find your .pkg
- Select the .pkg and choose for 'compress'
- Upload the .zip file (which will have one package inside NOT both, the installer and uninstaller) to Jamf

When I attached this new package, which I uploaded as .zip, to my Premiere Pro policy the deployment succeeded.

New Contributor III

@Musicmaker answer's is correct. I have been struggling for a bit with that but the best solution so far is to compress the PKG you get from the Adobe Admin Console on a Mac and THEN uploading to Jamf.

If you upload the PKG directly to Jamf, the server's compression will make the PKG fail at installation.

Contributor III

Manually zipping the Adobe installer package before uploading to Jamf is one piece of the puzzle. Another is to remove previously installed Adobe software before running the new installer. The big one for us is to reboot the Mac before running the install policy.

Going back as far as the Adobe CS days we occasionally experience the "The Installer encountered an error that caused the installation to fail" error. This happens on both Intel and M1 Macs and with or without other Adobe software installed. Running the policy again does not help however simply rebooting the Mac and trying again works every time. Now we tell users to reboot before running the policy in Self Service.

Valued Contributor

To get rid of all the old versions of Adobe, and to start with a clean sheet I have a script, which I found somewhere on Jamf Nation. I cant remember the post or who put it up, sorry. Whoever you were it is a good script.

The script uses the Adobe un-installers to complete its task. And it does the lot one after the other. Please Test it in your system and then test it again and again, before releasing it.


#  Uninstall Adobe CC
#  Created by Admin on 01/12/2020.
# loosly based on:
# and

function removeAdobeApps {

  uninstallDir="/Library/Application Support/Adobe/Uninstall"
  setup="/Library/Application Support/Adobe/Adobe Desktop Common/HDBox/Setup"

  if [[ -d "${uninstallDir}" ]] && [[ -f "${setup}" ]]; then
    adobeAppList=$(find "${uninstallDir}" -type f -maxdepth 1 -name "*.adbarg")


    for i in ${adobeAppList}; do
      if [[ -f "${i}" ]]; then
        appName=$(echo "${i}" | awk -F "/" '{print $NF}' | cut -d "." -f 1)
        echo "Attempting to uninstall ${appName}"
        sapCode=$(grep -e "^--sapCode=" "${i}" | awk -F "=" '{print $2}')
        echo "sapCode: ${sapCode}"
        prodVer=$(grep -e "^--productVersion=" "${i}" | awk -F "=" '{print $2}')
        echo "prouctVersion: ${prodVer}"
        "${setup}" --uninstall=1 --sapCode="${sapCode}" --productVersion="${prodVer}" --platform=osx10-64 --deleteUserPreferences=false

    unset IFS
    echo "No Adobe apps found to uninstall"


# Start

echo "Start first try..."

echo "Start second try..."

# Uninstall Acrobat DC 15
if [[ -f "/Applications/Adobe Acrobat DC/Adobe" ]]; then
  echo "Attempting to uninstall Acrobat DC 15"
  "/Applications/Adobe Acrobat DC/Adobe" "/Applications/Adobe Acrobat DC/Adobe" "/Applications/Adobe Acrobat DC/Adobe"

# Uninstall Acrobat DC 18+
if [[ -f "/Applications/Adobe Acrobat DC/Adobe" ]]; then
  echo "Attempting to uninstall Acrobat DC"
  "/Applications/Adobe Acrobat DC/Adobe" "/Applications/Adobe Acrobat DC/Adobe Uninstaller" "/Applications/Adobe Acrobat DC/Adobe"

# Uninstall the Creative Cloud Desktop app
if [[ -f "/Applications/Utilities/Adobe Creative Cloud/Utils/Creative Cloud Cloud Uninstaller" ]]; then
  echo "Attempting to uninstall Creative Cloud Desktop"
  "/Applications/Utilities/Adobe Creative Cloud/Utils/Creative Cloud Cloud Uninstaller" -u

exit 0

This works very well, I have it running on Big Sur as well.
The alternative is to write your own script. Pretty easy to do.
Set up a blank Mac, Run composer and do a Normal snapshot of the drive. Then set all of your Adobe Apps to install. Run the snapshot to find the files. Now you have a convenient list of all of the files installed. Write a script to remove them. Send it out to your Macs.

Problems installing...
In the past I have found SMB share points will damage an Adobe Installer PKG, as will transferring them via SMB. Adobe uses its own standard of pkg, and the move via SMB is not good for them.
Zipping or tar.gz and then extracting locally on the Mac is the way I go. So I compress the pkg in a tar.gz. and then use Composer to make a pkg of that. Then the pkg will "install", place the pkg in a known location. where a script will then run and extract then install the Adobe pkg file.
So far in tests on both Silicon and Intel running Big Sur this is happy on my system.

New Contributor

I feel like I'm missing something. I've created a CC only package. Self-Service. M1 specific. I download the downloader. Open the DMG. Download the actual installer. Unzip the file. Move the install PKG file out of the folder its in. Recompress the PKG. Upload with Jamf Admin. Save when upload finishes. Configure policy to install with Self Service. Wait about 5 mins for everything to sync. Reboot. Try installing with self service.... it downloads and still gets the same error.

Installation failed. The installer reported: installer: Package name is AdobeCreativeCloud_NamedM1_04162021
installer: Installing at base path /
installer: The install failed. (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance. An error occurred while running scripts from the package. 

EDIT: I tried with the universal installer. Same result. 

EDIT 2: I did see after some testing that the manual install pkg is being flagged as an unidentified publisher. Would that cause these issues?


This should help everyone with this annoying Adobe issue....

1. unzipping the original .pkg from Adobe after the download;

2. locating the core _Install.pkg file from within the Build folder;

3. repackage and zip the _Install.pkg file and to prepare it local for upload into JSS;

4. upload this new .zipped .pkg to JSS;

5. deploy it through a policy as you would any package to selected workstations 



Yes, this process does work.  This is what I have been doing as well.


In case anyone is having these issues still: Adobe is not signing their packages when it generates them from the Adobe Admin Console.

Instead of letting JAMF zip the package up when uploading, manually zip the .pkg up from the build folder and then upload it to JAMF. Was able to test it on a number of machines (Universal install) and it works. 


Also, folks, please check out  Daz Wallace's post regarding this workflow.