Apps staying grayed out


Hello all,

Im am currently 18 days into a support ticket that doesn't seem to be getting anywhere and I was wondering if anyone has come across (and conquered) this same issue?

All of the iPad apps district wide are grayed out. They show up on the device but they never download. Tapping the app brings up the "unable to download done/retry" pop up. Clicking on either of those options does nothing. Tapping on the app again brings up the "unable to install you must purchase this app to install it" pop up.

We've been through all of the basic stuff... yes theres enough licenses, changed networks, scoped and unscoped, changed configs, deleted the pending from the history commands, renewed VPP token, even removed from the jss and reenrolled. No luck.

Whats odd is that in the history management tab the command says its completed, but the app never downloads.

Im sure you all can imagine 18 days of 2000 iPads being stuck in limbo is not a good thing and patience is running thin for everyone, including myself.

I was wondering if anyone has gone through this and maybe has a direction that I can point the support team in? They have done thundering heard, they've taken my jss down multiple days for hours at a time with still no solution, so I appreciate any and all help!





Disregard the orientation of that photo (thats what kind of Monday it is)
But that is what the apps look like on all iPads.

New Contributor

I'm looking for a solution for the exact same problem. It's not happening to all of our apps, but there are many students with at least one app that does exactly what you describe. So far I've able to get an app to install correctly if I delete the grayed-out app, update inventory on the device, restart the device, and re-download the app from self service... but there's one device today that just won't install Microsoft Word with any amount of coaxing. My next step is going to be a support ticket as well, so I'll make sure to reference this post since it seems we're having the same issue.

Edit to add: Now affecting multiple students school-wide, all with the one app (Word).

Contributor III

I see this occasionally w/ a single app ... MS Word this AM (others mentioning issue w/ Word on Slack). I hit cancel (vs retry) and clicked the app for it change from grey and then launch. I was able to reinstall from Self Service shortly thereafter w/ any issue.

Edit ... scratch that comment on Word as it's still flaking out w/ "Unable to Download App" messaging.

New Contributor

I am also experiencing this with word as well

Release Candidate Programs Tester

Hit by the Word issue here too.


We are also having this issue with Microsoft Word

Contributor II

+1 on Word not installing. Reported yesterday AM from one of our collegiate units.

New Contributor III

Same here! Something wacky went on with the versions now it doesn’t install at all.

New Contributor II

I'm in the same boat. Apps that used to install fine are having issues. Even basic app cleanup on activation is slow and tedious. We are hosting our own JSS if that makes a difference.

New Contributor II

Same. Still no answer from anyone at JAMF. this is disaster for us as a 1:1 district. No new students can get their required apps. Unacceptable.

New Contributor III

I can also confirm Microsoft Word is also the main offender for our deployment, however a couple of other unrelated apps are exhibiting the same issue. Minimal impact so far, but interesting that it's isolated to only Word and not the other suite apps from Microsoft.

New Contributor III

I am also having the same issue with Word and yes just word .... the rest of the Microsoft suite is working as expected.

New Contributor III

for anyone else trying to work this out I just heard from Jamf support

"Thank you for passing that discussion over. You're certainly onto something, and this appears to be a known issue. We have it filed on our end as PI-006259

It appears that iOS apps updated on iTunes after September 10th, 2018 are not installing via MDM.

We have confirmed that Microsoft Office (including Word) is one of the affected Apps.

Right now, we do not have a workaround or fix in place; but we do have an AppleCare ticket filed currently, 100639602054."

New Contributor II

My issue with grayed out apps is NOT just microsoft apps. It is Microsoft AND Google(all google apps).

New Contributor III

@udadmin i think that’s covered in my comment above here “It appears that iOS apps updated on iTunes after September 10th, 2018 are not installing via MDM.”

Contributor II

I've got Two JAMF instances affected by this, so far it's only Word...

New Contributor III

This is happening to me as well. Other Office apps acquired via are deploying correctly. NOT WORD.

New Contributor

The only app I am having this issue with is Microsoft Word. Is everyone getting the same error? "Unable to Install "Microsoft Word" You must purchase this app to install it." This is incredibly frustrating.

New Contributor III


Thanks for the update. It may not be isolated to just apps updated after the 10th, as I have one app, 'Cisco Webex Meetings' where the last known feature update occurred around 29th August.

Unless of course, you're referring to the actual process of updating after the 10th September. If that's the case, then apologies!

EDIT: So According to the "Unable to Download Apps" error, I have 18 items listed as 'could not be downloaded' on one device.

New Contributor

Seeing this in our environment as well - we’ve been investigating reports of staff unable to install Flipgrid and MS Word.

New Contributor III

just heard back from Jamf support “We've been informed by Apple that the issue with MS word has been fixed.”

I need to un-scope the app from devices that failed to install the app and re-scope them again.

it’s after hours for me so won’t be able to test until tomorrow ... if there is someone who can try this let us know if it worked :) otherwise i’ll let you know tomorrow


I tried the un-scope and re-scope with a few recons and pushes without success.

If I delete the greyed out app on the device it pops back on successfully...

New Contributor III

We were experiencing this exact problem with apps like Word, Flipgrid, and Hudl. Just now, I was able to install them all with no problem on devices across the district. So maybe the issue is resolved on their end? Just passing along in case anyone else would like to try in their district or environments.


+1 for us on this issue.

For Microsoft Word I performed the following:
- Browsed to App in JAMF Pro
- created an exclusion for my test device
- App went white with the grid in the middle
- Forced an update and send blank push - no change
- removed exclusion
- app installed successfully

We have the apps set so students cannot uninstall apps.

I hope this helps.

New Contributor III

We were informed today that Apple released a fix which addresses this issue. Word, Fligrid and Hudl were the only 3 apps that were mentioned.

Tested and Word installed without issue.

Valued Contributor III

I also can confirm that Apple fixed something server side and device assigned, newly updated apps are again installing. Unscoping is not necessary, just delete and redownload.

I feel sorry for the OP as the thread has filled up with an Apple issue. My only thought for @Howard.Trevor is IF the apps are no longer active in the DB they should show up in a debug log as "App: APPNAME is disabled - will no be removed or installed".

New Contributor III

I can also confirm that Apple has fixed the non installation of word issue
I performed the following:
Deleted the App if its greyed out on the iPad
Exclude the user/device from the scope for the App
Ran an inventory update on the iPad
Removed the exclusion
Re ran an inventory update
The App then download

New Contributor III

I can also confirm that Word is resolved at our end as well.

I deleted the app from the device and pushed an inventory update which installed the app successfully.

On a separate note, it turns out that an error has appeared in my Failed Commands list for the other app, which I'm looking into.

New Contributor

I'm having this issue with Word and Cisco Webex Meetings.

New Contributor III

@whereiswaldo7 From what I gather, the issue with Cisco WebEx Meetings may appear to be a licensing issue. I'm just about to submit a ticket to confirm.

Contributor II

We have 3800 iPads. We noticed this already in August this year, and I reported to Jamf. Jamf then contacted Apple, who 'kinda' helped, but wanted us to purchase an Enterprise Support to fully help. I then called Apple and the support technician tried to do what he could but taking it up the chain. We supplied Log files to both Jamf and Apple, and as of Sep 25, it still isn't working on our network.

Strange thing though, if I take iPads home, and use configurator to erase them, all apps will install. In the school district it takes a lot of time to get all the apps to install.

Since August, we have "prepared" which includes erasing, over 3,000 iPads. We have many apps 'Pushed' out to iPads depending upon requests from teachers. Typically between 10-30 apps are pushed out to each iPad. Not once have we had a 100% success since August. Yet when I take the iPads home, it is always 100% success.

We have 9 elementary buildings where we are 1:1 with iPads. IF an app continues to say "Retry Installation" we turn our phones into 'hot spots' and the apps will then install right away. If an app stays 'grayed out', we must delete the app on the iPad, go into Jamf and delete the "Pending App" in both History > Management History AND History > Apps, then Update Inventory. Sometimes we just give up on the Push and install the app via Self Service. Either way, this is a huge time waste.

Our network engineer claims we are not filtering at all in our Administration Building (and true everything works quickly and other than several apps not installing, no other problems). Also, we typically will have all apps install no problems except for 1-4 apps, and it isn't always the same apps either.

We have tried Caching Servers, USB Caching Servers, and NO Caching Servers.

Today, I am going to try updating iPads to iOS 12 and erasing.


@bvondeylen When you say filtered are you saying you have no content filtering present in that (admin)building or is it that bandwidth throttling isn't present? Certainly sounds like bandwidth throttling to me. If caching servers in sufficient enough numbers aren't helping then it seems like the last hop traffic is being throttled in your school buildings.

What's your wireless infrastructure like? Do you have an AP in each classroom?

Contributor II

We have a 10G pipe to the internet (will be 11G soon). We are using about 2GB daily.

We have an AP in each room, but I have also come in on a Saturday when no one else is in the district and had the same issue. It isn't bandwidth.

By filtered, I mean our Firewall. We have set our firewall to be open at the AD Bldg (we have no students here) and we are having the same issue with app installing.

I have also set USB Internet Sharing ON on the MacBook Air I am using for Configurator 2 which hasn't helped the apps to install either.

I have been on the phone with both Jamf and Apple trying to figure this out (several times since August) and it just hasn't worked.

Today, I Restored 4 iPads so they would update to iOS 12, and then I watched apps installed. Some I had to click "Retry" for them to install, and several just didn't install at all ('grayed out'). Going through the Delete App, Clear History, Update Inventory, got them all installed, but nursing this along is not fun.

It all worked without problems last school year.


@bvondeylen Did you ever get your issue sorted out? No matter what I tried, no matter what our network team tried, and no matter what Jamf support tried, the only way I could get it done was to change my configuration to allow for the user to manually delete that apps, and then to re-push the apps back out. Couldn’t get the apps to do anything on my end since they never technically “installed” and having the users do it took a few weeks. Had to have our help desk send out email after email setting up schedules for apps to be deleted since I didn’t want that configuration open when students were using the devices as they would go on a deleting spree. It was definitely a mess. Hasn’t happened since so I have no idea what caused it, but would really like to avoid it happening again.

New Contributor

I had a similar issue and this thread is one of the first results so this may help someone. In my case the issue was the iOS was too old to support the app.

Valued Contributor

It appears I'm seeing this with an app called TestNav which is used for standardized testing in schools.
We are seeing about 10% failure rate of auto install.

iPad OS is 13.7 - 14.2
Plenty of licenses available.
The icon was grayed out with the word Waiting.

When clicking on the icon we were presented with the following message:

Unabelt to Install "TestNav"
You must purchase this app to install it.
View in the App Store

We would click OK, then delete the app, and then go to Self Service to download.

I have had this particular situation happen on several iPads what we did to fix them

remove restrictions 

Edit homescreen - tap on - sign remove app

in Jamf - go to record - history - app - cancel all pending apps

Restart ipad

add restrictions back - this normally fixes the issue.   I only do this on an individual basis, out of 3000 iPads over 4 sites I think we had about 50 that this happened to.  Regularly every year.