AutoDMG and NetBoot

New Contributor III

Hello! Long time lurker, first time poster.

I've been reading up on AutoDMG and it seems like a pretty neat tool and is something I would love to leverage in our environment. I have created a 10.9.2 dmg, uploaded it to Casper Admin and have successfully imaged a few lab machines in target disk mode via Thunderbolt.

However, when I try to image those same machines via our NetBoot server, the Mac refuses to reboot and sometimes will display a flashing question mark folder or go straight into a kernel panic. Am I doing something wrong? Is AutoDMG not compatible with NetBoot? I am running JAMF's NetSUS appliance but I've also built a temporary NetBoot server on an extra Mavericks machine I had laying around. Same results.

Any suggestions? If AutoDMG is not going to work with NetBoot, what's the best alternative? Something like this?


Valued Contributor

This might be helpful;


AutoDMG creates a never booted image that can be restored to a hard drive using asr. This could be deployed via Casper Imaging or DeployStudio or any other tools that leverage asr to block copy this image to the hard drive.

Netboot is a completely different system. Netboot is where you boot up a machine over the network from a .nbi file created from a tool such as system image utility.

So it sounds like you are having a problem getting your client machines to even netboot...well before you even start to deploy an autodmg created image to these target machines.

How are you creating your netboot image? If you are attempting to boot old equipment around 2010 or earlier then you may run in to the kexts over 32mb issue as noted in the link above.

New Contributor III

Oops, sorry for the confusion. I might have worded my original question wrong.

@Kumarasinghe and @calum_carey I did have issues with creating a 10.9.2 NetBoot due to the kernelcache being over 35MB, but that is a different issue. I have a working NetBoot server and I am able to image using the more @jhalvorson described in this post.

When I target mode image using the OS I have captured via AutoDMG and deploy it via Casper Image, the target workstation will boot just fine. When I introduce NetBoot, the target workstation will boot to NetBoot, appear to image just fine with Casper Image, but never reboots correctly after that. I have successfully gotten a target workstation to boot to both a JAMF NetSUS appliance NetBoot and a OS X Server NetBoot, but neither can image the machine successfully using the OS I captured via AutoDMG.

Valued Contributor

@weidemij - the idea of thin imaging is to not replace the OS that came from the factory. The name thin imaging does cause some confusion. I've stopped using that term and now follow the logic posted here:

When you create a base OS with AutoDMG, it's purpose is to replace the existing OS after erasing the drive. It sounds like your config for "thin" imaging includes the .dmg from AutoDMG. That would write on top of the factory OS with base OS that doesn't work on that system or muddling two OSes together. (Knowing the build number of Mac OS would help. Reference this page to know which model needs which build

Within Casper Admin, I have two configurations for building 10.9 systems.

  • The first one is titled "Arrived with 10.9 from Apple, OurCompName Customize Only (Do not erase disk)". It's a Standard Config with 31 packages and 6 scripts." This is what our configuration center uses when we receive new computers from Apple. This could be called Thin imaging.
  • The second is titled "Rebuild 10.9- Erase disk, installs OS, and OurCompName Customize" it is a Smart Config and the parent is the config listed above. They only additional package it has is the .dmg created by AutoDMG. This is primarily used by our support techs for break/fix or clean upgrades.

New Contributor III


Thanks for the tips. I am using the wrong terminology to describe my situation with thin imaging, but I am definitely trying to accomplish a workflow similar to what you described in your second bullet point. I am booting the machine to our local NetBoot server, erasing the target drive via Casper Imaging, and selecting a very simple configuration with just the AutoDMG OS and a few basic packages for testing. The whole thing falls flat on its face when it reboots.

Alternatively, I can take the same machine, place it in target disk mode, attach it via Thunderbolt to my iMac, launch Casper Imaging, erase disk, and use the very same configuration (with the same AutoDMG OS I created) to image it.

The fact that I'm using a NetBoot server seems to be screwing the whole thing up somehow.

Valued Contributor

Which version of the Casper Suite do you have in place and what version of Casper Imaging is in your Netboot?

Within Casper Admin, take a look at the .dmg that was created with AutoDMG.
Verify the following:
General tab - Uncheck "Item is a DMG with an OS X installer, or Adobe Updater/Installer for CS3 or CS4".
Options tab - Set the priority to 1, check Requires restart. All other options are left unchecked.

Does your config include packages that are set to "Install on boot drive after imaging" and/or scripts that install at Reboot?

While Casper Imaging is installing the base OS .dmg created by AutoDMG, it should take a while to copy down the OS partition and then you might be able to witness the progress bar will start over while it's installing the recovery partition. Do you see that or is it simply blasting past the OS .dmg?

[We are using Casper Suite 9.22. My net boot image is 10.9.1 (13B4116) and also 10.9.1 (13B3116). The server is Mac 10.9.2 with Server 3.0.3.)

New Contributor III

I am currently using Casper Suite v 9.24. We just upgraded a few weeks ago. The NetBoot server is running Casper Imaging 9.24.

Within Casper Admin, I have confirmed the following settings:
- The Item is a DMG with an OS X Installer... is not checked.
- It is set to priority 1. Requires restart is not checked. (I have now checked this box per your recommendation and re-imaged again, but it did not change the outcome.)

I have tried several different configurations, both with and without packages that are required to be installed on the boot drive after imaging. Currently, I am just testing the OS from AutoDMG with no additional packages.

I can confirm that Casper Imaging is taking the appropriate amount of time and is not blasting past the .dmg.

Valued Contributor II

@weidemij, what happens if you netboot a test system then instead of using Casper Imaging, manually mount your CasperShare via afp, then use Disk Utility to erase the internal hard drive of the test system and use the Restore in Disk Utility to restore your base OS dmg. I'm curious if using the restore function in Disk Utility will properly restore the dmg file and allow the computer to boot properly. If this all does work, then you might want to consider testing older versions of Casper Imaging to see if the problem is related to the Casper Imaging application itself. I am using version 8.73 and haven't had any problems using Casper Imaging with Netboot.

Valued Contributor

Also try a imaging configuration with a software (PKG) install at imaging time.
e.g. JavaForOSX-2013-005.pkg with "Install on boot drive after imaging" unchecked.



I found the 9.24 version of casper imaging has problems with smart configs.
Using the 9.21 version even with a 9.24 jss works fine.
However i'm a massive fan of deploystudio and try to avoid casper imaging like the plague for many reasons such as creating the netboot image is a pain in the ass, it just does weird shit ilke your seeing and i feel that deploy studio gives me greater control over who has access to what configurations/workflows etc etc etc

New Contributor III

Thanks for all the advice. I'm sorry I wasn't able to reply sooner, but I've been having an issue with our distribution point. In fact, having this DP issue might have solved my imaging issues.

@mpermann This is when I first noticed something was up with our JDS. We are having unrelated certificate issues, so I wasn't able to test out your suggestion. We have temporarily moved to an old fashion file share DP as a backup and now our image is working as intended. Go figure, huh? I am working with support to get our JDS up and running again, so I will test things again later on when we move back to our JDS.

@calum_carey I think the smart config issue is unrelated, as I am just using a single, standard configuration for testing right now, but I'm glad to know I'm not the only one with this issue.

Release Candidate Programs Tester

@weidemij, you can also try creating a never booted OS dmg via Casper Admin & then add the DMG to the Standard Config that the smart configs are based off: