AutoPKGR not Uploading to Jamf

New Contributor

Good Afternoon,

I have been setting up AutoPKGR and after a few stumbling blocks, all the software is up to date (all green), the JSS importer is configured (Green light) with separate account with permissions, Repository has been selected and a couple of pkg's have been selected. The pkg's download locally and there is no error; however, it does not seem to automatically upload to Jamf. I have put an override in place for the recipe's as well but cannot seem to get the Autopkgr 'magic' to work.

I supect the issue is that we have a Cloud Distribution Point in Jamf but from threads, some have this sorted. Any suggestions would be appreciated.

Best Regards,



If you have a CDP you have to use JSSImporter 0.51 instead of 1.x. There are issues with 1.x and it breaking functionality to get uploading to a CDP working.

New Contributor

Hi Afarnsworth,

Thanks for the quick response; So I indeed had 1.x so i uninstalled it and installed 0.51 as suggested but I am running into a new error preventing me from testing the change:

AutoPKG 1.0.04 is citing an update is available; running the Update process but does not update (I encountered this before and its linked to the JSSImporter version, so I can ignore this)
JSSImporter is citing update available (as expected to get the process working)

When I attempt to update Repos or add a Repo, I get the following error:
"Error adding Repo
A Python exception occurred during the execution of autopkg, see the system log for more details.

[ERROR] : No module named cryptography"

I am not seeing any unusual activity in System.log.

If I uninstall JSS 0.51, AutoPKGR is "up to date" and I can select Repos and run recipes. Is there a workaround/fix for the cryptography issue?

Best Regards,

New Contributor III

Hi All,
I am running 2 JAMFCloud instances. One of the instances works great with JCDS and the latest JSSImporter version. Uploads happen and thereafter autopkg runs. I had another where packages would just not upload no matter what version of JSSImporter I ran. I spoke with my STAM and we found quite a few JAMF Product Issues mainly to do with uploading packages via API and having spaces in package names seems to produce issues as well.

I seem to have somewhat resolved it by spinning up my own CDP in AWS. I believe @rtrouton has an article on his site on how to set this up as well. Ever since moving to my own CDP in AWS, I have not had any issues. I am using the Latest version of JSSImporter on 10.13.6. I am also using this to run the autopkg runs as with 10.13.6 I ran into some issues with Autopkgr GUI scheduler. Hope this helps!

Here are the versions running on the 1 JAMFCloud instance that has no errors;
JSSImporter: python-jss version: 2.0.1.
JSSImporter: JSSImporter version: 1.0.1b4.
JSSImporter: JSS version: '10.8.0-t1539715549'
macOS 10.13.4

HERe are the version where I had to use my own CDP:
JSSImporter: python-jss version: 2.0.1.
JSSImporter: JSSImporter version: 1.0.1b4.
JSSImporter: JSS version: '10.8.0-t1539715549'
macOS 10.13.6


@sstott Sounds like you are missing the pyopenssl module. If you have pip installed on the box run pip install -I --user pyopenssl and you should be good. Can also take a look at @rtrouton blog as he has great articles on automating a lot of the setup.

New Contributor

So I have built a new VM fusion instance running:
Mac OS 10.3.6
AutoPKG 1.0.4
Git 2.2.1
JSSImporter: 0.51

After running:

Sudo pip install cryptography
Sudo -H pip install cryptography
Sudo -H pip install requests
Sudo -H pip install paramiko

(some of this may not be necessary, but it illustrates what I've run to make it work)
Sudo -H fixed a lot of the installation issues but there was a folder I manually created (can't remember its name) to allow an installation to complete.

Confirmed the Settings with
defaults read com.github.autopkg JSS_URL
defaults read com.github.autopkg API_USERNAME

Added repo
autopkg repo-add rtrouton-recipes

I was able to run
autopkg run -v MalwarebytesAntiMalware.jss

This confirmed for me autopkg was working so I turned to AutoPKGR. I created local overrides on select recipes to get around some 'trust' issues.

I bashed my head against it for some time, (coming up against several errors), I checked the system log and confirmed the package was being created locally, but could not see anything about it uploading to Cloud Distribution Point. Until at the end of the day I checked Jamf packages and saw that in fact it had been uploading the files despite throwing an error: "404 Response: Not found. The server has not found anything matching the request URI"

I am not sure what this error is; it originally occurred with all the recipes. But ran fine this morning, until I added another recipe and it replicated again. Any ideas what is causing this error?2e30415e0bf64d31a99fc532c51f1f92