Avaya IX Workplace

Contributor II

Has anyone packaged Avaya IX Workplace? What I received is a .dmg file with two .apps in it - one is installer.app. Any other means than to mount the dmg, run the .app and then have users follow instructions? Would like to package and pre-configure...


New Contributor III

Hey @Lhsachs ,

i've managed to deploy it in our environment by first chaching the necessary files via composer and then another composer package that will install those files.
Right now it seems to work just fine, also with Catalina. The Avaya Workplace version we have used therefor is

Best regards,


@Lhsachs ,
Did you ever figure this out?

Contributor III

Any PPPC settings to be aware of that we can set from Jamf?

New Contributor III

I am in the same position. Once I get this working I will post how I put it all together.

New Contributor III

Thanks you Morti for your post because it gave me some insight on how to build it but here are the steps I took.
1. Just as stated by Morti create a package in Composer. Make sure to place all Avaya IX Workplace install file on a location on the local drive. ( i.e. /Library/Application Support/JAMF/holdingarea )
2. Create a policy that is responsible for copying the files that are mentioned in step 1
3. Create a BASH script that is responsible for kicking off the installer
(i.e. sudo installer -verboseR -package Avaya IX Workplace.sparkle_interactive.pkg -target / )
4. Create a policy that is responsible for installing Avaya IX Workplace. Add the script create in the 3rd step, add a dock icon for Avaya IX Workplace

To uninstall Avaya IX Workplace
Create a policy and add "Files & Process" and place "/Library/Application Support/JAMF/Waiting Room/AvayaIXWorkplace/Uninstall.app" in the Execute command field. You can add an Dock icon to remove the Avaya IX Workspace icon from the dock.

That should do it.

New Contributor III

Late response, but I created a policy that include a package in Composer that had the Application as well as some certs we require that were dropped into a hidden folder on the OS. In the same policy, I added a payload for a script that imported the two certs that were dropped by the package. There were reasons for not including the script as a post-install in the package, rather than having a separate script otherwise that would have been a more tidy way to do it.

I also had to create a config profile with the PPPC payload to allow AddressBook, AppleEvents, and Calendar for Avaya.

New Contributor III

Thanks "Poormatt". I forgot to add that. Thanks for adding that the PPPC payload needs to be created too. Spot on.


FerPeteSake why do they hide the pkg?

I have been struggling with this myself, and want to share my finding. I could not locate the Avaya IX Workplace.sparkle_interactive.pkg from previous posts.


It turns out the (most important and useful) .pkg file is just a hidden file on the mounted volume that contains the installer.
To show the hidden files, command+shift+. will do it.


Copy those three files Install.app, Uninstall.app, and (in this version) Avaya Workplace.sparkle_interactive.pkg to your temporary folder.
Make a composer pkg for those
I set my policy to install the package that puts the files in place, then I end with a Processes command at the end.

/path/to/your/tmp/AvayaWorkplace/Install.app/Contents/MacOS/install -silent

That way, I am running the full vendor script with its logic that roots out old versions and deals with them, if they exist.

New Contributor III

@chris.hansen Working on an installer for a newer version and came across the hidden files "by accident" today. Came back to update on my prior post and saw yours - good pointer on the CMD-SHFT-. I always forget that shorcut.


@poormatt and @chris.hansen, I really appreciate you sharing your knowledge on this. This stupid app has plagued me for months.

New Contributor III

Hi, all. This thread has been incredibly helpful deploying Avaya IX Workplace 3.8.0.

Question: Are you fellow Jamfer's using the autoconfigURL? I've specified it based on what we're using with our Windows MSI and I'm still stuck manually typing it in via the cog after first run for the app.

Thanks in advance!

Valued Contributor

Example of how to build a package using Packages.app


The postinstall script. The script includes optional commands that record details to a log file: CompanyNameInfoTech.log


# Variables used for logging

# Logging funtion
log () {
    echo $1
    echo $(date "+%Y-%m-%d %H:%M:%S: ") $1 >> $logFile  

log "-----"
log "Begin install Avaya Workspace 3.17.0"

# Determine working directory
install_dir=`dirname $0`

# Change to working directory
/usr/bin/cd $install_dir

# Install the FireEye HX agent
$install_dir/Install.app/Contents/MacOS/install -silent

log "Completed Avaya Workspace install"

exit 0  ## Success
exit 1  ## Failure

Valued Contributor

Here is the PPPC configuration profile that works for us.
Notes: 1. We do not use the video conf feature - so no reason to allow camera.
2. I believe you can deny microphone, but a configuration profile can't "allow" it. It's still up to the user.
3. The access to contacts and calendar are for the Apple Address Book app and Apple Calendar app. Since we use Outlook, I have set those to deny.


New Contributor

Not sure if anyone is still looking at this thread, but I did what @jhalvorson did above in packages and get the below install errors from jamf:

Installation failed. The installer reported: installer: Package name is Avaya.3.18
installer: Installing at base path /
installer: The install failed. (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance. An error occurred while running scripts from the package “Avaya.3.18.pkg”.)

Any Ideas?

Valued Contributor

@john.massa Before you added the "postinstall" script to Packages, did you run the command to make the file executable?
Typically I use this command on the file:

sudo chmod u+x /path_to/postinstall

The install.log on the device may explain what failed. (The path is /private/var/log/install.log)

If you are new to Packages, I recommend checking out @rtrouton site for hints and tips https://derflounder.wordpress.com/2016/01/14/creating-an-office-2016-15-18-0-installer/

New Contributor

@jhalvorson Thank you! I've made a half dozen other packages using Packages and never had to change perms, but that seemed to do the trick! Thank you again!

New Contributor

@jhalvorson May I ask where/how you found the Code Requirement for the PPPC ?

Valued Contributor

@john.massa I used the PPPC Utility by Jamf - https://github.com/jamf/PPPC-Utility.
When you drop an application into the PPPC Utility, it will display the Identifier and Code Requirements. With that information, I created the Configuration Profile within the Jamf web console. I didn't save or export it from PPPC Utility. Times when I do save the configuration created by PPPC Utility, it's used as a learning aid and I compare what is build by Jamf Pro.

The addition of the AppleEvents Allow was based on other people's posts.

New Contributor

@jhalvorson once again, thank you so much, I greatly appreciate it!

Contributor III

@gwertman Did you ever find out if it's possible to add an autoconfig url during setup? We also use an Outlook Calendar with client user/pass so that may be the only user interaction if I can get the autoconfig url to populate.
Also if the Avaya IX app is already installed does this process or similar work to update it without ruining the existing client install?
My guess is we'll have to manually install once and then try and use these processes or similar to update the app.
Any help is greatly appreciated.

New Contributor III

This is the install command that I'm using, and it worked perfectly. The installer path and autoconfig url would be different of course. I haven't tried to update an existing install, but I can't see why that wouldn't work.

/private/tmp/avaya/Install.app/Contents/MacOS/install -silent -autoconfigURL https://baseurl:411/workplace.txt

Nice avatar pic! That's doable!

Contributor III

@gwertman thanks for the info. I guess I'm doing some testing!

New Contributor

i followed @chris.hansen steps and was able to install with no issues, but when i add the -silent -autoconfigURL https://baseurl:411/workplace.txt command after the install command as mentioned by @gwertman , it reveals my hidden jamf management account user folder to the following path /jamfmgmt /library/application support/com.avaya.Avaya-IX-Worplace/installlParameters.plist. has anyone come across this issue and figure out a way around it?

New Contributor

Hi, has anyone gotten this to work with the lastest AvayaWorkplace I'm new to packaging and couldn't get this to work. Imported the package into Composer and then did Convert to Source, created the directory path. When the policy runs on the client I can see the folders and files on the mac but it does not execute.


I have tried from the path above as suggested I get an error that the file does not exist. If I remove "-silent" then I get the message, "install exists and is executable" but it does not install the application?

/path/to/your/tmp/AvayaWorkplace/Install.app/Contents/MacOS/install -silent

 Can someone let me know what I'm doing wrong. Thanks.


I haven't used that version, but when I did AvayaIXWorkplace-, I just used the Avaya IX Workplace.sparkle_interactive.pkg as a regular package, which installed just fine. 

Jason Filice