Big Sur: Jamf wants access to control Dock

thomas_moser
New Contributor III

Hi all,
and a good new year to all of you!

Does anyone else get this query?
When installing a policy with a dock icon on a Big Sur machine we get asked to allow Jamf access to Dock (see screenshot).
I am not sure on how to enable it. I tried it manually with the PPPC utility to allow Jamf to control the Dock but got an error with the installation of the profile.

If anyone has a solution I would be grateful for the config used πŸ™‚

BR Thomas
398db413ffe54e8aa5cf5b6f37428656

7 REPLIES 7

MatG
Contributor II

@thomas.moser

We get the same, only noticed this since Jamf 10.26, at first I thought it was M1 Mac's only but we see it on Intel as well.
I have had an open ticket with Jamf asking how to suppress since the first week of Jan.

If you have come up with fix can you post?

thomas_moser
New Contributor III

Hi MagG,
in our case it was apparently only with Skype for Business (v16.29.41).
All other apps/policies worked just fine. So it seems the issue was with this SfB version.
Sorry that this might not help, hopefully you can get it working normally again on your side.

BR
Thomas

kaurloto
New Contributor II

Any update on this issue? I'm having the same problem. We're installing SfB on our devices but it's not included in the Dock payload, we're only doing dock icons for:
Self Service
Firefox
Google Chrome
Microsoft Teams
Microsoft PowerPoint
Microsoft Excel
Microsoft Word
Microsoft Outlook
Microsoft Edge

Philein
New Contributor III

Same here. Any solutions?

NOVELLUS
Contributor

Hi everybody, we are creating the users dock, too, but we do not have this issue. We configure the dock with a policy.

AdminIA
New Contributor III

@NOVELLUS Are you able to get the policy the remove items from the dock? I can't seem to get it to do that.

user-EJcFiFjrbG
New Contributor

I am having issues - coincidentally or not - with Apple apps. I am starting to think this is by design. Policy works beautifully with any other app. It feels like a silent tug-of-war where Apple does not want for a mac admin to remove their apps from the dock.

It's just a though but I am seriously considering this possibility.

My issues are only with Big Sur and Facetime, TV, Podcasts, LaunchPad, and Music.

I tried all of this paths with no success:
file://Applications/TV.app
file:///Applications/TV.app
file://System/Applications/TV.app
file://System/Applications/TV.app/
/System/Applications/TV.app
Macintosh HD/System/Applications/TV.app