Big sur on VMware fusion enroled as iOS device .

New Contributor II

Hi, I recently installed Big Sur in VMware fusion and tried enolling the device with user initiated enrolment. This installed the CA cert and MDM profile but the device wasn't showing in Jamf . Later I enrolled the device with QuickAdd package which didn't install the CA cert and MDM profile but policies worked and the device is enrolled in Jamf, but as iOS device . Then I did a user initiated enrollment and installed the CA cert and MDM profile .

Is this expected or I missed anything ?



Did you set the VM up with a valid Mac serial and model identifier? I know the random "VM####" serials end up in the iOS bucket.

You'll have to right-click the .vmwarevm bundle, Show Package Contents, and edit the $VMName.vmx file. Add, for example:

serialNumber = "C02BBBBBBBBB"

You might also need to add, I can't remember if I added these but they're present in my DEP testing VM .vmx files.

serialNumber.reflectHost = "FALSE"
hw.model.reflectHost = "FALSE"

If your VM host Mac isn't enrolled, you could probably try to set just the last to to TRUE and seeing if it'll enroll that way.

Contributor III

@balakumaran I had the same issue with a VM with Catalina, trying to enroll it with user initiated enrolment
I think it was due to the fact the same computer was still assigned in my DEP prestage enrollment but could not double check yet

Valued Contributor

Thanks for this. I had completely forgotten this was a thing (QuickAdd avoids this, but Big Sur, quickadd doesn't work). Surprised this hasn't been fixed yet (this has been a bug with Jamf for... 3+ years at this point seems like).

fwiw, I only needed to set the serial, and model. that got the binary to download and install, and the enrollment to succeed as a Computer.