Casper Imaging -> 10.7 Netboot Image | Not working...

Contributor III
Contributor III

Guys my imaging fails with Casper Imaging, I am at wits end and I think that I am going to go back to Deploystudio.

I created an netboot image based on the knowledge based article

Everything is working, boot ups, has some issues about running out of disk space but it does image the machine but no matter what it restarts and doesn't do the firstrun script.

I have to have 90 imaged by Friday and I am freaking out a bit that I can't seem to get this working

Does anyone have the same issue? It is not working...



New Contributor II

Are you netbooting when you are imaging the system? You have to image as Root for first run to work correctly. Ran into myself.


Contributor III
Contributor III

My workflow form casper imaging...

![external image link](attachments/be785a0455ea4ce280b8a1e347796b6f)

Honored Contributor II
Honored Contributor II

I know it's a lot of work, but have you tried imaging jus the OS and
On Tue, Nov 1, 2011 at 6:19 AM, Rob Potvin <bisjamf at> wrote:
nothing else to make sure it works? Whenever I have problems with an
image, my first test is a config with just the OS (10.7-Vanilla.dmg in your
case) to make sure that is fine.

I would start there, and then if that works, I would probably go for the
items that you are installing on first boot (1to1 stuff) to see if those
install properly. So your config would be the OS and the first boot items.

Steve Wood
Director of IT
swood at

The Integer Group | 1999 Bryan St. | Ste. 1700 | Dallas, TX 75201
T 214.758.6813 | F 214.758.6901 | C 940.312.2475

New Contributor III

This may be obvious - but have you checked that the Adobe stuff is set to "This package must be installed to the boot volume at imaging time?"

Not applicable

We've had a similar problem with our 10.6.8 image. It turned out, the folder /System/Library/StartupItems was not in the image, therefore the FirstRun script setup, was not created properly.

So in relation to your screenshot, try checking your 10.7-Vanilla.dmg image and check if the /System/Library/StartupItems folder is there. If not, create it and re-upload the dmg into Casper. See if that helps out…that seemed to fix our problem of the FirstRun script not running in our 10.6.8 image.


Contributor III
Contributor III

Will have to try that and see.

Adobe installers are after restart hence their position


Contributor III
Contributor III

StartupItems folder is there

It restarts before Prepare FirstRun Script... maybe on rename or when updating byhost files, have to sit down in front of it and watch.

Only had this problem with 10.7 and unfortunately need to image these machines 10.7, new macbook airs...

Anyway will have a look and see

Contributor III
Contributor III

Full netboot and its the root account, autologin is set to root user...

Esteemed Contributor II

We recently rebuilt our LAB environment from the ground up. Lion Server, Lion clients, and the latest version of JSS (right now that's 8.31).

We followed JAMF KB 236 (which I notice was recently updated) to create BaseImage, RestoreImage and NetBoot image.

We saw the "disk is full" error during reboot, but we dismissed and imaging worked fine.

No issues on the server or clients. We are following standard NetBoot process.

PS, I still miss JSS Setup Utility dearly...but the new Java version seems to be maturing nicely...


San Fran Geek sanfrangeek at


Contributor III
Contributor III

Okay so I redid everything, I copied the InstallESD.dmg (newest one) to Casper Admin (checked the OS Install bit)

I created a new installed called 10.7.2

I then added that to my image

Removed old InstaDMG build from the list and then has Casper Imaging do it's thing with everything fresh.

Computer images, copies Adobe installers for post install restarts to Macintosh HD and it restarts into 10.7.2 Recovery HD and doesn't actually install 10.7.2 and the software.

Does this happen to anyone else?

Not applicable

Be sure you do not have selected install on root on the hard disk for the 10.7.2 image
I had this issue also.


Carmelo Lopez Portilla

ITS EMBL Heidelberg
Tel. +49 (0) 6221 387 8444
Fax +49 (0) 6221 387 8517
email: lopez at

Contributor III
Contributor III

Could you elaborate, not sure what you mean?

Valued Contributor II

I had the same issue with the 10.7.2 and doing a compiled image. I must
have tried creating about 20 images over the course of 2 days... never
got a single one working. Finally went back to my old 10.7.1 with
10.7.2 combo + Recovery update layered on top. It works, but layering
the Combo + the Recovery partition is a lot of wasted time when imaging.

The day before I upgraded from 8.21 to 8.31, so I wonder if that was
why, no real way to test it at this point though.

John Wojda

Lead System Engineer, DEI & Mobility

3333 Beverly Rd. B2-338B

Hoffman Estates, IL 60179

Phone: (847)286-7855

Page: (224)532.3447

Team Lead DEI: Matt Beiriger
<mailto:mbeirig at;jwojda at

Team Lead Mobility: Chris
<mailto:cstaana at;jwojda at
edback&body=I%20am%20contacting%20you%20regarding%20John%20Wojda.> Sta

Mac Tip/Tricks/Self Service & Support

"Any time you choose to be inflexible in your approach to an
unpredictable project you are already building failure into your plan"

Not applicable


I mean on the Casper Admin to have not checked " This package must be installed to the boot volume at imaging time

Here I attached a screen shot


![external image link](attachments/334a5ee3777247748a1fa93fe83ec52b)

Contributor III
Contributor III

oh yeah of course it is unchecked



Release Candidate Programs Tester

Tbh. I had issues & ended up compiling my 10.7 base image.